New answers tagged

0

This could be a good start https://www.youtube.com/watch?v=lY8Ol2n4o4A Comprehensive guide to Camera tracking & integration. https://www.youtube.com/watch?v=lY8Ol2n4o4A Quick overview by the incredible Ian Hubert.


1

You can use vertex colors. If you paint a mask in black and white in Vertex Paint mode(ctrl+tab -> Vertex Paint) and then mix your desired shaders or textures using vertex color node, the textures will blend gradually: You can make various gradients from a lot of things with nodes so this is probably not the only solution. I would recommend not to limit ...


0

I solved the problem. I did not use shape keys at all. This can be done by copying the UV-mapping from the source mesh onto the target mesh (c.f. https://docs.blender.org/manual/en/2.79/editors/uv_image/uv/layout_management.html). Since both objects have the same topology, this is straightforward.


2

I believe some of your face normals are flipped OR you have overlapping faces / really rough topology, OR you need to unwrap your model more cleanly without UV distortion and maybe even increase the UV texture resolution. To fix normals: Tab for Edit Mode, then A to select all. Ctrl+Shift+N to recalculate normals (untick "inside"). Fix overlapping geometry:...


2

Turns out the answer to "why is it brown" is that the subsurface scattering color was pink and I had the slider turned up really high. -sigh- It's always something little like that isn't it EDIT: here is a screenshot of what it looked like after I altered the subsurface color


0

Ok, I figured it out. my Subsurface slider was turned up too high..


2

I don't know whether this suits, you might be wanting more of a simulation of real lenses. But we have an unusual advantage here in CG-world .. the projector can know how far away it is from the points it's projecting onto, via a Ray Length output of a Light Path node. By similar triangles, (multiplying the normal by the ray-length) the spherical look-up, ...


0

This issue was resolved by adding a Normal Map in the PBR node setup. Missed that earlier...


4

You can use the Bias input, and as @Gorgious suggested, a Map Range node. Set Brick height/width to 1, so it matches the Checker texture Add Checker texture and Map Range node with To min set to -1. Use Mapping node to scale both textures to 8


5

I would use a checker texture (Or use this answer to modify the bias in the brick texture to behave like a checker) and darken the color with the black outline of the brick texture afterwards : Note : The scale of the checker texture must be 2 * that of the brick texture, otherwise the edges won't align.


0

Use a better lighting, possibly with an HDRI in your scene. A part of the reason why the textures look unreal is that they are completely grey and flat. Use image textures and include slight bump mapping for things like the fake leather and so on. What I like to do is get, for example, a leather texture that might be any colour just for the texture, then ...


0

It looks like your image texture is not mapped correctly on the surface, did you check, if your Texture matches your UVs? And add a Texture Coordinate and a Mapping node to your Material-Setup. The easiest way to do that is to use the Node-Wrangler-Addon (CTRL+T Shortcut), it should be activated by default in blender 2.8, select the Principled BSDF Node and ...


3

I could be wrong, but I think the halo is caused by the very same phenomenon as the inversion, that it can be expected, and it's made more obvious by the low resolution of the roughness map. Let's divide the material into three regions for the sake of argument: glossy, semi-glossy, and rough. Where the glossy is directly reflecting a dark backgound, the ...


0

Have your image loaded as a texture Set your material Base Color to the texture you want With Object Mode in the 3D Viewport Set Viewport Shading Color to Texture If anyone can elaborate on how to attach multiple textures to a mesh's UV that would be excellent !


-1

you have to use opencv a python library for image processing so that you can map a full image.


2

I recently experienced a similar issue. I found that, by default, images textures are set to sRGB; Setting the normal map's image texture's color space to "Non-Color" should correct the issue;


1

The issue is caused by UV stretching, which is a result of deforming the mesh with a displacement AFTER the model was already UV unwrapped. Open the UV Editing tab Hit the N key to open the side bar Expand the overlay section of views Tick the box that says Stretching Now you will see something like this: The dark blue areas are good and have little or ...


0

I solved it! I have the problem in shaders, used noise textures without connecting uv map: Connecting like that: Now its working perfectly!


2

I found another method to correct keystone distortion thanks to this paper. It too has its limitations. I guess if you take an average of this and my previous setup, you would get the best result.


3

I made a node group. It isn't perfect but works just fine for non-extreme cases. Hope this helps This node group can be further condensed, but it is better this way for better clarity. To know what Horizontal and Vertical inputs mean see: Keystone Correction


0

After you baked your multiple textures into one texture, you need to tell the material of your object to actualy use this new Texture. Eyther create a new material or alter the old Material to use this new Texture.


0

Does something like this work for you? If you want to blend the textures, you can use gray instead of Black or White; Different Shader on same label Note: While this uses nodes in Blender, you should be able to blend textures in your game engine using a similar process, and the textures you create in blender would carry over.


0

You could use Ctrl+Z undo (or) Hit TAB, to go from Edit mode -> Object Mode. Then hit x (or) delete and delete object. Now, select your donut and Hit again TAB to Object mode -> Edit mode now select the part of the mesh that you want to make icing with by selecting each vertice individually (or) hit Numpad 1 to goto front view and use b (or) use c which ...


0

If you are referring to the frosting mesh intersecting the doughnut mesh, you can modify each vertex of the frosting so that it is not clipping. This process is easier in x-ray mode, because you can see each vertex. After enough time with the editor, you will get used to how to read the 3D space. Until then, you can select a vertex, then hit numpad ., and ...


1

First, I'll note that by default, textures loop endlessly. Given that, despite the fact that your UVs are "off the texture", the texture is still being applied with the same coverage, just at a different scale. To fix your issue, you may want to employ a Mapping node. Setup Let's start with the node setup; Note: for the "Type", I've selected "Texture", ...


1

Instead of directly connecting the UV Vector output from the UV Map node to the image input in the material nodes, insert a Vector > Mapping node. You can use it's scale component to scale the existing UVs, or move/rotate them. For scaling only a Vector Math node set to multiply will do just as well. This will obviously not work in an exported object for ...


0

There's no issues at all (that I've ever encountered at least) with scaling up your UVs. This is a common way to deal with tileable textures. Another way is to scale the texture in the material settings, but this does the exact same thing, just behind the scenes, and probably won't export as nicely. One thing to consider is you also don't want higher ...


4

If anyone has the same issue, I found the answer. So this was filmed with a phone and it could be that the dimensions weren't quite right so my camera cropped a bit of the video. So that was pretty much it.


0

Blender fbx importer is a bit rudimentary. Neither the exporter nor the importer supports nested textures. So you will have to find a way in Poser to export the maps manually. The import option has a checkmark "Image Search" which is on by default. If your images are labeled correctly, it should be able to assign them to the according channels. If not you ...


0

If you have a texture image than you probably forgot to Choose it for your UV.Go to UV than select new file (locate that image) Now turn the edit mode and go back to UV tab and make the highlighted cubes fit the whole image. If you already have an image selected than it must be because you haven't done the shading part correctly.


2

As far as I know you can't modify the default setting easily but you can use a simple node group to force the behaviour wherever you want to use your image texture node : Related : https://blender.stackexchange.com/a/168033/86891


2

Some of the texture files were missing so I used the waves texture instead.


0

What you need is BAKING. I recommend looking up some tutorials on texture baking in blender. Ideally, you should have used some color pallet and put uv faces on it to assign different color to different faces and using only a single material. you can then do a cleaner unwrap and bake the textures to this new uv map to get the final texture.


1

It looks like your "Viewport" and "Render" subdivisions are set differently. Depending on how you're rendering, that can make a huge difference at values that low (0-3 really). It may also be affecting baked cloth simulations. I recommend setting them to the same value. Possibly also bumping it up to 3.


0

In case someone comes across this, I finally found the same problem asked before with an answer that solved it: blender 2.8 texture paint material mode not showing shaded object, just flat color is shown?


1

One sloppy logic-block way is to make a duplicate of your character model, put it on a hidden layer, then use the Edit Object actuator and Replace Mesh drop down option. The hidden layer character model will have your alternate material (texture included). ad: I say sloppy because if you do this as a programmatic alternative, you're gonna have a hidden ...


2

At its simplest, that's probably selecting the face in Edit Mode (Face), and from the right-click menu, selecting 'Shade Flat'.


3

You can try using a grayscale image to set the factor of the scale of... heh, the scales. That's an incredibly esoteric thing to say, so here is my setup (please forgive my liberal use of "reroute" nodes, I wanted to fit it all in at a decent resolution); Which results in this (with the "factor" texture that's used in the above node setup, but you can paint ...


1

I downloaded the OBJ file and imported it, and sure enough; I've seen this issue before. I don't know if it's the default in blender, but my "Clip Start" value was incredibly small (0.01m). I changed it to 1m, and the model looks fine now; Edit: It's also worth noting that this model is massive. I scaled it WAY down to work with it originally. However, I ...


0

That's because you're in Solid view, where textures don't appear. Switch to Material Preview or Render Preview and your textures should be there.


2

You can divide the perspective out of a perspective camera's texture-space like this: .. and scale it to the desired size in the texture, a Mapping node, or multiplication.


1

The mesh wasn't selected entirely when I applied "Smart UV Project". Now, all faces have texture.


1

You don't appear to have marked any seems. If you didn't use "Smart UV Project", the UVs are going to be all tangled up. Andrew (the guy in the video) starts talking about Smart UV Project and how to mark seems for more intentional UVs at the 4 minute mark in that video.


1

Data Transfer modifier to the rescue: In your case, the mapping sounds as if it should be via Topology


0

Multiple objects can use different parts of the same material using UV mapping. In this example, The original UVs of the image plane are cut automatically when using the Knife tool. Split the edges and separate the loose parts to create multiple objects. Note the single material used. That same material can also use the same UVs for applying alpha, normals ...


0

Not exactly realtime but hitting Tab twice (goes into edit and back) after a stroke of texture painting will update the geometry right away.


0

There are two things to prevent those transparent faces. For Cycles - add some thicknes to the whole wall, before extruding individual parts For Eevee - Set material Blend Mode to Opaque Cycles - add thickness before extruding. Just extrude the whole plane first. Eevee - set blend mode to Opaque


1

To view all the undoable steps, go to Edit > Undo History and you can select which step you want to revert to. Blender keeps track of a ton of actions such as selecting / unselecting objects, so that's most likely whats going on. You can also increase/decrease the number of undo steps that Blender remembers in the User Preferences.


0

Blender 2.83 - moved under >Cursor >Texture Opacity.. or Under Overlays


0

I guess you haven't UV unwrap the mesh. Select the object, in edit menu and Unwrap it by clicking "U" and you can either do it manually or select the Smart UV to unwrap. Check this video to understand it: https://www.youtube.com/watch?v=Y7M-B6xnaEM If you actually did it but still it isn't showing, then you need to share the blend file along with the ...


Top 50 recent answers are included