New answers tagged

2

Try something like this - It still needs some shader to handle the transparency, but that doesn't mean you still can't still connect your image as an unshaded input (The plane in the image below is only there to show that there is a shadow gradient being generated by the point light, which is not affecting the texture with transparency): Don't forget to ...


5

If a Texture Coordinate input is not present, the space in which the Gradient > Linear is measured defaults to Generated. Generated space measures 0-1 along the sides of an object's bounding box, aligned to the object's own X,Y and Z axes. In that space, the minimum X of your sphere's surface maps to 0, and its maximum X maps to 1. An un-rotated Linear ...


1

Since your using the object coordinates, I think it might be caused by not applying the transformation. I presume you changed the scale of the object somewhere. so the solution is to apply the transformation :D Select the sphere and hit Ctrl+A and select All transformations.


0

See my setup below. It's a common misconception of how you use SSS. SSS color should determine the base color, while subsurface radius actually determines the color.


0

PROBLEM SOLVED. I just selected object which didn't display material, went to edit mode (TAB) and pressed Assign in a material window and it started to display material.


0

You will have two materials in the model. Blue material will not show if any other material is above it. In my screen shot my model is not showing red material because there is blue material above it.


0

in case anyone finds this small post sometime in the future, this video offers somewhat of a solution. Just do what he does in this section with whatever texture you want your shadow to conform to.


2

I can't tell you with 100% certainty without doing testing that you could do as well yourself-- really, testing that only you can do, because the details are going to depend on your specific machine. Blender compiles shader nodes to shader code that runs directly on your video card. One optimization of these cards is that they're designed to do "SIMD&...


1

You could just use a setup like this... ...Except for the top and bottom, where the UV unwrapping is not just a grid: (blue lines above show the wireframe from Christopher's solution) Which hints this might be the XY problem. The X problem is how to draw the meridians and circles of latitude, which you actually mention in your question; the Y problem is ...


0

This code example and related image demonstrate creation of new vertex attributes and using them in the shader network. I was not able to create string based attribute Its important to use cycles to easily see the results when using vertex attribute values higher than 1.0 import bpy from bpy import data as data, context as context from mathutils import ...


0

Maybe you could try separating the longitude area or whatever area is causing the problem with Separate -> Selection (keyboard shortcut P) and convert it into a different object and apply the modifier(s). Finally, you can join the objects back together with Ctrl + J.


1

As Allen mentioned, it's hard to tell with collapsed nodes (I know it's downloaded and not your fault), however, If I had to guess, I would say the "flat shaded look" is intentional (provided by the Wave Texture), and is meant to replicate those old-fashioned style glasses. That being said, the reason for the "loop cut" look is due to a ...


3

Un-check the box that says Replace Original on your Wireframe Modifier settings. If needed, you can also add additional material slots to your object and change the material of just the wireframe (or surface) by changing the Material Offset (if, for example you want the latitude/longitude lines to be black instead of the surface color, give the second ...


0

From your explanation, here is what I think will make it look the way you want.


1

You do this by inserting color correction nodes between the image texture's Color output and the shader's Color input. In this case, I would probably use an RGB curves node to adjust the red tint, so my shader might look like this:


1

First turn off Glossy in the Ray Visibility panel in World Settings. Instead of a Glossy BSDF and Transparent BSDF into an Add Shader, plug it into a Mix Shader instead. You can then vary the Fac to determine how transparent and how reflective the material is. I can then see through the windows and keep the reflection of the objects without the HDRI image ...


1

After looking into view layers (which I never really had before) thanks to Gorgious' comment, I found the best solution was to have one view layer in which the top character was disabled from the view layer and the bottom character was set to "Set indirect only". Then another in which the Mirror acted as a holdout as well as "set indirect only&...


4

you can get this result with CYCLES: The torus (without mirror) has this nodes setup: Suzanne (only mirror) has this nodes setup: blend file:


0

Maybe you need to recalculate faces normals ? This can be found in Edit Mode (while wrong faces are selected) under Mesh > Normals > Recalculate Outside.


0

You can use any of Blender's pre-packaged lighting environments in your scene. Example: Starting with a basic material on Suzanne, looks great in Material Preview Scene doesn't look right in Rendered Preview Create a split screen, and change one area from 3D Viewport to Shader Editor. Toggle Shader Type from Object to World. Ensure Node Wrangler Add-on is ...


2

Under Object Data Properties go to Geometry Data and click on the button that says Clear Custom Split Normals Data. I don't know why you have added custom split normals data on your mesh, but this gets rid of the black. Also disabling Auto Smooth under Normals makes the glass transparent again, but this shouldn't be the problem if there were no custom split ...


1

I found out that I needed an actual hollow space, faked it with a solidify modifier and joined the other objects I wanted to block the light with to the original mesh.


5

I made something pretty similar to what you show, that is a mix between Diffuse, Transparent, Glossy and Glass. You can probably get rid of Diffuse: As for the glass you need to push the Transmission value up to 1, lower down the Roughness value, in the material Settings choose Blend Mode > Alpha Blend and Screen Space Refraction, and in the Render panel ...


2

I don't think there is any problem with the shading of your mesh, it's just the reflection of the light from that particular white ceramic matcap as the issue isn`t shown in any other matcaps. To be honest I am not completely sure. Your mesh previewed with the white ceramic matcap Your mesh previewed with the red metal matcap


3

When you switch to smooth shading, for geometry like yours, you should also enable AutoSmooth by going to the Properties Panel; selecting Object Data Properties; (the one with the triangle icon,) opening the Normals tab and enabling AutoSmooth: Here is geometry that is similar to yours, with smooth shading enabled. Without autosmooth set: With autosmooth ...


3

If you need to put your blue pattern over the b&w lines, you can use this kind of setup (below). If you need to erase some parts of the pattern, you can do it in the 3D view and in Texture Paint mode use an Draw brush > Blend > Erase Alpha:


0

In the context output section make sure you have the Render Region (under Dimensions) unchecked, should fix your problem.


1

If you can use a newer version of Blender, there's denoising feature. It is so easy to use, you only need to check a checkbox. Here's where you can find it on Blender 2.93:


0

Try deleting any additional materials on the mesh. You might be receiving an error like No active image found in material "Wheels" (0) for object "fifty.001" In my case, I just deleted that material from the mesh, and then the bake worked fine.


10

For the moment you have large and non-planar ngons, it creates these artefacts: You need to change your topology, for example this way:


2

The BSDF you plug it into doesn't matter. The way that the normal map is treated doesn't depend on what it ultimately feeds. As you realized, a tangent space normal map is made out of (remapped, -1,1 to 0,1) vectors in tangent space. An object space normal map is made out of (remapped) vectors in object space. The output of a normal map node is expressed in ...


2

You could use a Wave Texture node before a ColorRamp, or another kind of texture that you stretch on the Z axis, use another texture before if it needs to be a bit deformed, but Wave Texture has a Distortion value:


0

I did some research and the answer is "tangent space". It's actually a surprisingly complicated concept. In short, it depends on both the face normal and the UV unwrapping. https://learnopengl.com/Advanced-Lighting/Normal-Mapping


1

I don't know why that's not working for you; I probably couldn't say without a file. However, what I would do in that situation is a little different, and testing it out, it works just fine: Rather than creating a separate volumetric mesh, which is never going to completely agree with the ocean surface, I simply solidified my ocean. In order to flatten ...


17

In your example, it works for the given input, that is a value 0.2 produces 1 output: value is both greater than 0.1 and lesser than 0.3, both condition nodes outputs sum up to 2 which is clamped into the 0...1 range, so becomes 1. However let's see what happens if your value is below the 0.1...0.3 range: it passes only one condition, but since summing 0 ...


13

You can do it with a Color Ramp node. Set the interpolation to Constant, bring the black stop to the position 0.3, the white stop to 0.1 and add a black stop at 0.0.


1

If no channel contains color data, use non-color. Otherwise use something different - sRGB is a good first guess, but ideally the provider of the texture should tell you what is the color space used. Non-color sRGB or different roughness, glossiness, metaliness, normal, displace, ambient occlusion albedo, diffuse, base, subsurface, emission Disclaimer ...


8

Musgrave Texture is a pretty good candidate for breaking up an outline like this, since it outputs values between -1 and 1 it won't offset your coordinates. On average everything will be centered around the same point. You can use MixRGB on coordinate vectors and it will operate on each channel as though it were RGB, and you can use it as a vector input ...


2

You could do some touches manually. Try editing the texture "by hand"... Just like if you were making a PBR texture or drawing... The darker a color is, the deeper it will look. And the lighter the color is, the more popped-out it will look... For example, paint with a darker shade (of the same color of the sand) for a deeper effect in a certain ...


2

Try selecting your model and then going to View>Frame Selected My first guess is that maybe you're zoomed out/panned away from the model in that view?


0

It looks like maybe your normals are flipped. Check this box. If your glass looks like this - Enter Edit Mode, select all with A, press Alt + N and select Recalculate Outside. Your glass should look a bit better, but it looks to me like you should consider adding some supporting geometry on the top and bottom.


3

Sometimes what we DON'T WANT is the go. Have previously commented on questions / answers where the poster was indexing by number that indexing by name was "better" more readable etc. Then around about the time of this answer Principled BSDF via Python API I discovered that changing the blender language, also changed the socket names. (This appears ...


1

You are using an image called donut texture in an Image Texture node of your material. Open the Image Editor and look what is this image, it's nothing else than a render of your donut, so you're just projecting an image of your donut on your donut. You need to use another image (or paint over this image):


3

you cannot group the normals in blender, however there is a very easy workaround to this problem that I have used myself. go into edit mode, tun on show normals. then, select the faces of the normals you want to group, press alt+n or find normals in the mesh dropdown and then press point to target. nothing will happen click anywhere and you should get ...


6

Plug your 2 differents displacement maps (here Noise Textures) into a MixRGB and use a black and white mask image as a factor in the MixRGB in order to separate the 2 areas: You can't use a Mix Shader for this purpose, Mix Shader is used to mix shaders, like Diffuse, Emission, Principled BSDF, Glossy, etc.


2

Some Split Normals have been set to an unusual direction, it happens with imported FBX for example, so go in the Object Data panel > Geometry and Clear Custom Split Normals Data:


4

In the View Layers panel > Override, remove the selected material, otherwise you'll make it the only one showing for all your objects:


0

in the "viewport shading" view normally there are no textures. This is default behaviour (there are exceptions). If you want to see textures, change to material preview or rendered view The "solid" viewport display is made for building/moving/creating things and good performance. That's why textures aren't shown because they tend to ...


1

As usual with nodes, there is more than one way to do this: Here, I am using the Y position of the UV coordinates as the factor to mix my texture color into white. I am also using an RGB curves node to distort these coordinates to control the exact gradient. Not asked for, but recommended. Many people would use a (possibly remapped) gradient texture ...


1

You could e.g. use this mesh: result:


Top 50 recent answers are included