New answers tagged

1

In case anyone bumps into this problem: This was being caused by the noob issue of z-fighting. I managed to find a work around by creating a couple big n-gons, adding a hook to the high-res geometry and then using a copy location restraint locked to the z axis. This solution allows for having dynamic high-res deformation sitting on top of a low-res plane ...


2

Your Clothes collection has Holdout enabled. It means it "draws" transparency: (drag the image around the browser to see it's transparent, not white) In order to disable this effect either select your Clothes collection, go to Collection Properties and click on Holdout to disable it: Or enable the Holdout option in the outliner and then disable ...


1

as Jachym commented here is an example: here with part glare: (as you wanted, solution via mix node and mask image) without glare: (i just muted the glare node) with full glare: (glare connected to viewer instead mix node to viewer)


0

If someone comes by and just needs a quick and dirty workaround: Place a plane with a Glass shader in front of your Camera. This will make standart Blender Lights visible to the Camera. Note: this will be slowing down your overall Rendering and probably come with some other sideffects. To speed up rendering set IOR and Roughness to 0. Also there is someon ...


2

It's normal behavior as color values climb above 1 (Standard View Transform) or 16~ (Filmic View Transform). You need to use a volumetric shader or some other method to create a gradient where the center of the star is white and gradually fades out to your desired color at the corona.


0

I don't know what was possible in 2015, but the ability to create Node groups means that you could just select all of the nodes that you want to copy from the source material and use them to create a single node group. (Shortcut Ctrl–G) Once you have a nodegroup, it is possible to simply add it using the add command and navigating to the Group submenu and ...


0

Well, I never did get an answer on this one. I did find a work around, though. I turned on the Emit pass, put it through the glare node and output it as a png. There was no transparency in the file, but, since the background rendered black, I was able to bring it into photoshop and knock the black out. I also rendered the girder/laser layer and placed it ...


1

Wipe Out my windows and get a clean and fresh installation on Windows. update with the latest Nvidia Drivers, and OptiX drivers and voilaaa problem solved. The Optix option now can be selected in the Edit-Preferences-System-Cycles render devices - OPTIX


0

First, try denoising. It appears that your render hasn't been denoised. If you don't know how to do that, go under render properties, sampling, denoising, and then check off render, but not the viewport.


9

Your Environment is disabled in View Layer Properties > Filter:


2

The Nishita model is described in the paper Simulating the Colors of Sky. The Blender Nishita Sky model is based on an updated version of the original model, but is very similar. The difference between a sky model such as Nishita and the use of an HDRI is that the sky model attempts to deal with the way the atmosphere filters the light. In a sky model, if ...


0

Make your cup, go into Edit Mode with Tab, press A to mark all lines. On the top left behind the Edit Mode line in the menu Mesh > Normals Flip. The whole ⇧ Shift + N shortcut did not flip for me.


0

As the fine manual says only png, jpg, and openEXR file formats support writing EXIF metadata. So you'll have to write to one of those. openEXR is only supported in 2.93. Focal length equivalent isn't available, and nor is sensor size. That said, when I output png and openEXR with 2.93 it works, so if it's not working in 2.83, you may have encountered a bug.


8

That video is using Blender 2.83. However, since then, Blender changed the HSV sliders from "color picking space" to "scene linear space". See https://developer.blender.org/rBf193b1afb313bcb937a396f09da2b9903a0d2fc3.


1

I usually use an HDRI from NASA's SVS: Deep Star Maps. You can get a full sphere OpenEXR image in 4k that is very usable, or you can get 8, 16, or even 32k versions. Here's my world shader for using HDRIs. It allows you to rotate the map as you need. Just download the NASA maps, replace your world shader with something like mine, and plug the OpenEXR image ...


0

The default light bounces for Volumes is 0. This is a pretty terrible default, in my opinion, because it causes a couple of issues. One issue is that whenever the volume is behind another shader in the scene, the ray is reported as lost. Observe that this shape should be colored blue inside. If we raise the Volume bounces by just a couple, we start ...


0

for cycles to render something there has to be light, (put the texture in an emission shader makes it a light). but if you put it real far away then the emission might need to be stronger as well. Oh and you seam to do something with fog/volumetrics, be aware then that it eats light as well if its far away you wont be able to see it, i dont think fog exist ...


1

You can just call Object.update_tag() to update the actual display data: import bpy C = bpy.context # Set the engine to cycles C.scene.render.engine = 'CYCLES' # Create the primitive bpy.ops.mesh.primitive_plane_add(size=10) # Get a reference to the primitive shadow_catcher = C.active_object # Set plane to be a shadow catcher shadow_catcher.cycles....


0

The clue here is that you can change colors in the scene and nothing changes. That's because when you hit the render button, Blender sees that you have an image strip in the video sequence editor (VSE) and it renders the image strip, rather than rendering your image. The solution can be as simple as deleting the image strip. Or you can avoid the problem (...


1

So, turns out I can decrease the IOR of the glass material to something much lower. Even if it doesn't look too good, is still got the job done.


0

This is a mesh + a Grease pencil object, rendered in Cycles.


0

It could be any number of things, if you post the wireframe, or the area in edit mode that could help narrow it down! :) Some stuff to try, though: Merge vertices by distance to get rid of any doubled up geometry. Turn on Auto Smooth in the Object Data Properties>Normals area and mess with the Angle until it looks good and see if that helps. Probably not ...


2

so i went from to by going Render Properties->Film->Pixel Filter->Width and setting as low as it would go (0.01px instead of 1.5px) you'll probably also want to make sure Render Properties->Motion Blur and (with camera selected) Object Data Properties->Depth of Field are disabled


0

In the compositor workspace you can scale the image down, use a Pixelate node and scale back to original size. https://docs.blender.org/manual/en/latest/compositing/types/filter/pixelate.html


1

If you used cycles, then you can enable Persistent Data under Render Properties >Performance > Final Render. This way, only for the first frame object synchronization is performed or when the objects are changed. It comes at the cost of increased memory usage. See also here


0

The answer was a different subdiv-level on the emitter object between viewport and render. I am not sure wheather it is a bug or not, but the render is fine when I use the same subdiv-level for the render. The effect may be related to the "Use modifier stack"-option for the hair systems.


-1

The model looks weird in Eevee and Material Preview (which is similar to Eevee) because the materials have transparency enabled (Blend Mode is set to Blend) and Show Backface is enabled. Select render engine Eevee to see the related material settings. Select a mesh part, go to the Material Settings and untick Show Backface. Repeat this for all mesh parts/...


0

So, many months later I solved this problem. The issue is related to some vector math done in my procedural texture. The procedural nodes calculate a cross product with the Z axis to figure out which direction the surface normal is and uses that to rotate the 2D brick texture to align with the face. In the case of a normal which is parrallel with the Z ...


0

True! Problem solved disabling CPU from CUDA selection (Intel Core i5 9400F - Nvidia Asus ROG Strix 1060 6GB) and seems faster too! Not sure why, but not complaining lol


2

I agree with @moonboots, having two different collections holding your lights is the best option by far. Easy, robust, quick. The only thing that I would add (optionally) are few lines of code in case I wanted to have more control over it (separate it to different scenarios maybe, keep track of different groups of lights etc). Which I guess is an over-killer ...


0

This is because of the principle BSDF node, just make the roughness 1 and metallic and specular to 0. or use a diffuse bsdf.


0

Relatively new to Blender here as well but maybe it would be easier if you made the edge of the mirror a totally new object... give it some thickness, then apply the material to that.


0

Solved it. I did not select Film->transparent.


1

There are many ways to do this, so it is hard to advise more specifically for your situation without knowing more context, but when compositing, if you want to control the shadows or change the background you should have: The background The shadow without the hole for the object The object So you could render the shadows with transparent background and ...


0

you need to change this line here = bpy.path.abspath('/tmp/tex_tures') to your folder, else it won't work. Because the code searches for every png in that folder and then executes it.


0

I also encountered a situation where hair would show perfectly in the viewport render preview but not in an actual render with blender 2.9 cycles. The cause: the hair dynamics checkbox was unchecked.


2

In 2.8 you can click the filter icon in the top right, and enable 'indirect only' in the list of filter options. Use this to keep reflections and lighting but get rid of actual objects from render.


0

because the icosphere and the plane are in different layers, they dont interact with each other. You can either: 1- have the plane and the sphere in the same layer 2- duplicate the plane and move it to the object layer, and make it a shadow catcher and a holdout in Object Properties > Visibility


1

When I open the file, I can see that you are in Material Preview mode. Material Preview mode gives you a preview but don't take your world and light setups into account, so the render won't look like what you currently see, you'd better switch to Rendered Preview to have a better idea of what you'll see as final result. Also in the Render panel > Color ...


Top 50 recent answers are included