New answers tagged

0

Camera Properties > Lens > Clip End 100 change to above 120 m. Your Camera is clipped in view. You can see Start-End clipping by enabling Camera Properties > Viewport Display > Limits


0

Render operator is located in top row of app Render > Render Animation (Ctrl+F12). Check if under Output Properties > Post Processing > Sequencer is enabled. If it is not the case attach simplified blend only with a short sample of movie, so we can check. But if you are able to render with different codec I'm not able to help since issue lies somewere in ...


0

This can be done in Eevee. Give your object a tranparent shader, and set the blend mode to 'Alpha Blend' or 'Alpha Clip' in the materials tab. Make sure to keep the shadow mode set to 'Opaque'. You can't control the opacity of the shadows with this method, but it works for most cases. It also gets rid of the black square problem at intersections.


0

There is an addon known as auto tile size which comes with blender you just have to enable it in blender user preferences you can limit how many cores are used for rendering and it also offers advance sizing options. If still this doesn't works you may reduce voltage given to your cpu and limit its rpm speed in your computer's bios


0

Pink usually means that image texture path is lost (it requires re-linking). It might also be caused by wrong or missing Texture Coordinates mapping (material nodes)...


1

You appear zoomed-in. Even though you have selected the camera view, it will retain the last zoom selected. Each workspace will retain it's own zoom levels. Just zoom out and hopefully that will resolve it. Oh and turn off Lock Camera To View as this sometimes confuses things. Once re-orientated, you can turn it back on.


3

First, you can do it in the 3D Viewport only. Find a View menu, and click the Viewport Render Animation. It will render the animation right from the viewport, using EEVEE if in solid or material preview mode. If you disable screen overlays, you can easily get nice renders in EEVEE this way, however, this is limited and inaccurate (not enough screen samples ...


1

I lowered the "Specular" slider for the objects material that has the image using the shading tab. I did this for each object that has an image.


0

I discovered that this is a known issue of Blender 2.81. Seems to happen when 4 or more 3d noise texture nodes are used. Bug details: https://developer.blender.org/T69776 With Blender 2.82 Beta works properly, at least in my case.


0

When you export meshes with such issue to FBX, and then re-import the FBX, such edges are actually marked as sharp (which they weren't before). you can also easily remove those with Blender's clear sharp edges function now - so this seems like a bug to me. This is a 3D model from Daz that I am using in Blender which presents the problem: As seen in the ...


-2

Get glass material from: http://blendermada.com/materials/?engine=cyc&category=glass&keyword= Is it Cycles or Eevee? Refractions and reflections in Eevee are not so great. Use Cycles if is a still photo.


1

The displayed unit is megabyte, therefore you're using approximately 8.4 GB. The value is based on the performed memory allocations and can be higher due than your RAM due to virtual memory and swapping. The operating system can use your hard drive to allocate additional memory, in case all available space on the RAM is already in use. If you're trying to ...


0

Are you applying the modifier from the cut before rendering? It looks like Octane is rendering the shape created by Boxcutter, which exists in non-destructive model until you click Apply.


0

Looks like (with the help of @iponoo @zeauro & @ kologe from blender artists & blenderchat), it is possible. Here's the smoke shader, that works with the mesh shader to produce a WPP for both smoke and meshes- It works well enough for me to do a bit of 'deep' type comping- https://youtu.be/xgCA-D4ukJk In the video the smoke seems to be respecting ...


3

This is a result of too low render resolution. 1000px is just too low, and upscaling makes it look blurry. Render the image at 2000x2000px instead, and even with just 200 samples you'll get nice sharp edges (just tested it). Bonus: How to properly connect the Denoise node for best results :).


3

bmesh script. Add sphere, remove only faces with bmesh in object mode import bpy import bmesh context = bpy.context bpy.ops.mesh.primitive_uv_sphere_add() ob = context.object me = ob.data bm = bmesh.new() bm.from_mesh(me) bmesh.ops.delete(bm, geom=bm.faces, context='FACES_ONLY') bm.to_mesh(me) me.update()


0

There was an STEP importer Addon released for Blender 2.8x in January 2020. Details can be found here: https://blender.stackexchange.com/a/166443/15678


0

There are two good ways to do this: 1) Disabling renderer in the Blender Preferences. This does not fully remove the renderer from Blender, but just disables it so that it does not show. To do it, go to Blender Preferences (File > Preferences). Go to Addons, and search "Render", or the name of your renderer. The renderer should show up with the rest of ...


1

You're going to want to use Smooth Shading and Auto-Smooth Normals here. To enable Smooth Shading, select the object, right-click, and select Shade Smooth near the top. Smooth shading essentially takes the normals and averages them out, giving you a smooth look. However, you don't want that to happen on every edge. That results in hard edges being given a ...


0

I've solved this. Glow/glare is determined by a background (it bleeds out past the object). Text and shapes have no background like a transparent image plane would. Solution: Add a plane behind your thing that won't glow, and make sure to add it to the object/mesh. Make this plan transparent, and it won't render but it WILL provide the background needed to ...


3

You're compositing the blue background in. Enter the compositor and either mute the Mix node or remove it.


1

Your rendered video will always be rectangular. But you can add a mask over it, using the compositor Create a black and white image using Blender/Photoshop/whatever Add an RGB node, using the Mix node Connect your BW image into the FAC input How to connect a mask in compositor. The RGB node changes the background color.


0

In properties / dimensions / resolution you can chanche the resolution from 100 to 0 , mayby setting it to 10 % and look if it is ably to render something with that setting. if it can , it is possible that your render is just too heavy .... and you should consider renderign your scene in parts ... I think in newest version they are couled passes ... using ...


3

For now Intel's OpenImageDenoise is superior to all the other ones. From the release notes: Compared to the existing denoiser, it works better with more complex materials like glass, and suffers less from splotchy artifacts. It also gives better results with very low numbers of samples, which can be used for quick previews. It's just a post process so ...


0

You should probably reinstall blender. The reason your screen goes black is probably because when blender "crashes" he starts to pull huge amounts of ram so keep your task manager open and before he eats more than let's say 80% you force close it. If the problem keeps happening I can't really help you much. It's probably some system error.


1

Adding to the previous answer, the displacement mod is definitely what is causing the problem. If you look at rendered/material vs. solid, the displacement UV is making the texture (brick) look huge, while in render, the texture is much smaller. I would fix this by removing the displacement, subdividing the plane and doing like said in the previous answer, ...


2

Basically one can just render the masks of the objects as images, import them and generate the arrays. This process is the similar for materials (a mask for every material) and depth. The script can be (at least) run in 2.8x and 2.79b, just adjust the code with the commented code. If you use 2.79b, put blender in the same folder as the your python.exe. ...


3

If you over expose your render you can see patern. Render saved as PNG 8-bit. Nothing is pluged into Surface socket of Material Output node. Tested with Eevee, Cycles, Samples ... all same result. Even if compression is set to zero. The only difference did PNG saved as 16-bit. Completely black. So I guess OpenEXR will work as well. So the issue comes from ...


0

The first thing I noticed is that you're plugging the Color Ramp directly into the material output without running that first through a shader node like "diffuse" or "Principled BSDF". Not sure if that would fix your problem. Although, Considering your end goal of filtering out objects by the color value, you should look into the Cryptomatte feature. That is ...


0

Looks like you have a particle emitter on the earth object. Go to your particle settings and check to make sure "Show Emitter" is enabled. The screenshot below it's disabled so it wouldn't show in the final render (but it will show in the viewport render), make sure that box is checked.


1

As @RobertGützkow already mentioned in the comment, you have not only selected your GPU for rendering, BUT also the CPU. Selecting GPU Compute makes Blender render with all selected devices to speed up the entire procedure, while sometimes it is faster, it may even be slower, depending on the render and the devices as well as the render performance settings ...


0

Some processes have to be done by the cpu. At the latest if it comes to filling out the quads with picture while rendering your gpu should start working.


0

Try turning on this, and play with the angle setting. This model is a bit of a mess though, so many triangles, some don't look planar, those things are going to ruin your shading. Try to keep everything as quad as much as you can.


0

Couple of options without seeing the file. Check the "disable in Render" filter is not selected. An example is attached where the cross indicates that it will not be rendered The next check is you mention that you go to the composition workspace. Have you checked the "Use Nodes" option, this is off by default and so nothing is visible. Alternatively you ...


0

you can check if relevant objects are enabled/disabled in render. I usually prefer to show it in outliner like this: click on filter icon and activate the button with camera icon then you can see it in outliner and check if object is enabled/disabled for rendering and since you are using modifiers you should check if render is enabled for modifier too (...


1

The problem was that you set the Plane as a local camera here. So every time you pressed 0 key it, blender showed you the local camera set as the plane and thus you were seeing the inside of the washing machine. Just deselect the "Use Local Camera" checkbox, that would allow you to change the Local Camera. Select the camera of you scene using the eye ...


0

Install the Parallel Render add-on: https://github.com/elmopl/ktba/blob/master/scripts/addons/parallel_render.py Use it like this way: https://github.com/elmopl/ktba/wiki/Addons


0

Adding to the previous answer, the fact that the domain wasn't baked is likely a factor. You can re-bake the domain by going to the domain properties and selecting "Bake". (2.81 and before). If you are using an experimental build (2.82+), then mantaflow will be included. In the mantaflow domain settings, select "resume bake". I personally would recommend ...


0

My best bet is that the fluid was not successfully baked. That's why it turned back into the domain mesh. (I have noticed that it has been some time since you make this question and you may have already known this. But if not, hope it helps.)


5

Visualy screen looks like you have enabled Use Curves in sub panel of Color Management with some adjustment there. BTW When I see missing navigation icons in your screen, there can be graphic card issue ...


0

The only reason for this warning is that Blender is trying to read a TIFF. Objects are not the only things that might use TIFFs. You might check your skydome or environment texture. If you have BlenderGuru's Pro-lighting Skies, then it's probably loading TIFFs at some point. You may have some other addon that uses TIFF images. If you can upload a copy of ...


0

Turns out I just wasn't accessing the right object type. The movie clip node contains a clip parameter, which contains the data I needed. The frame end range can then be set like this: frameCount = bpy.data.scenes['Scene'].node_tree.nodes["MovieClip"].clip.frame_duration bpy.context.scene.frame_end = frameCount Full specification of the MovieClip datatype ...


0

I suspect the image textures are scaled down. The light marks are the "background" color of the image texture you are using. They appear precisely where your seams are. I'm sure there is some setting that does this and it may not be a default setting. You could work around this by dragging in the seams in your image texture more towards the center or maybe ...


0

Check and see if you have this option checked in your missing object.


0

When using glass, it is usually better to use cycles to get a more realistic look. However, there is away to achieve a "cycles glass look" with EEVEE. First, you can either use a principled shader and set the transmission to 1, or you can use a normal glass shader. Then, check Screen Space Refraction in the settings dropdown. In the render tab, check the ...


1

I had a similar problem a while back with cycles. I used a script for rendering on remote ubuntu systems with titans xps. Try running the following script IF you too have Titan xps, otherwise try to find the right blender-name for your GPU first. This may or may not work, I thought you may want to give it a shot. import os, bpy os.environ['...


1

Not direct answer, but maybe helpful if you choose the way of the viewport. The viewport is mainly faster because the GPU pushes the image directly to the screen instead of copying it back to the cpu for colomanagement and other calculations. So using the viewport, maybe directly pipelining it to whatever other output you seek might be one of the fastest ...


0

And as of version 2.81, it seems like the Blender API has once again changed, because @pistiwique's answer doesn't work for me. You can now use: # Set the device_type bpy.context.preferences.addons["cycles"].preferences.compute_device_type = "CUDA" # Set the device and feature set bpy.context.scene.cycles.device = "GPU" bpy.context.scene.cycles.feature_set ...


1

There is a chance that this is because your smoke material's density is too low and the pixels of your render only have rgb values but no alpha value, which is why the smoke can only be seen if transparent is turned off. You can check to see if this is the case by unchecking use alpha in the composite node, and see if there is any color.


0

Those white dots look to me like light fireflies. To fix this, use denoising. You can enable this in the second render collections tab in the properties panel.


Top 50 recent answers are included