New answers tagged

1

To have "transparency" you need some form of mask or map for it. Let's say you have two images: 1- The color information 2 - A "Transparency" or "Opaque" map, which would be a black and white image that determines what is "see through" (black) and what is opaque (white). Usually this information is embedded in an "...


1

Looking at the material, nothing is connected to the alpha input of the shader. Connect this, and then make sure in the material settings that alpha mode is set to “hashed” and not “opaque”.


0

Increase the roughness on a glass shader. No roughness: Some roughness: Even more roughness: Blur will work just fine with distance, the closer the object is to the window, it will be sharper.


0

You don't need true transparency (the Alpha slot of Principled BSDF) to create stockings. You can just mix the skin color with the fabric color and use this as the base color of the Principled BSDF. For black stockings add some black sheen/fesnel. Simple Stockings Shader for Eevee If you want to use the shader in Eevee only you can use a simple setup: Mix ...


1

I can just repeat myself from comment ... by using thinner thread you get bigger holes in knitting that brings your material from far view as partly transparent. And it is fully depend on you if you need such detail for close up look or you fake it by just darker/ brighter tone of skin for far view of whole leg. Here is example of knitting bump texture (...


2

The problem is that your node setup is ignoring the existing Alpha channel. Instead of overwriting it, you need to multiply it with your mask. I used the Separate RGBA node to extract the current Alpha value, and a Math node to multiply the two values:


1

Your viewport material's alpha is not set to 1, that's why your object is semi-transparent. Click on the Color field and set the Alpha to 1. The red color might come from backfaces. You can either recalculate normals with SHIFT + N or deactivate it in the overlays :


0

It's often wise to set up your material and open up a material or rendered preview viewport. You can have multiple viewports open. You can paint in either window. For alpha in a material preview, you'll need to set an appropriate alpha blend mode for your material, and to set that, you'll have to temporarily switch to the Eevee renderer-- material preview ...


0

Additionally to what you're doing you need to go to the shader editor, press N, go to options in the material you want this effect in, and find "Options > Settings > Back Face culling" uncheck.


1

One thing I know for certain is that this problem is getting less bad as I raise the number of transparency light bounces You've answered your own question right there. To avoid getting hung up tracing rays that will never reach a light source, Cycles has a maximum number of bounces for each ray. If a ray reaches that maximum number without hitting any ...


1

Move all objects that shouldn't have freestyle outlines to a new collection (you can select them, press M and create a new collection or choose an existing one). Then, in View Layer tab, inside Freestyle section, select the freestyle condition to also be based on a collection - then precise the new collection and choose exclusive to not draw over objects ...


0

so I think the reason this has occurred is your multiple pass shading has both overlapped and not quite joined when you've drawn it. Easiest fix is to draw the shading in 1 pass if you can. If that's not possible you could enter Edit mode and, ensuring your viewport is set to "Select only points" (This is the first button to the right of the Mode ...


0

Plug it into a color ramp and then make the white color transparent (Set the alpha to 0)


3

Mix your Image texture (through a shader - emission is possible) with a Transparent Shader, using your images' alpha as a mix factor. As you can see in the image bleow, there are no lights in the scene. It works in both cycles and EEVEE, but keep in mind, in Cycles it will actually emit light without further modification to the shader. If using EEVEE, ...


1

There is a very easy way to achieve this. If I understand you correctly, you have an HDRI or any other image as Environment Texture in the world background, and you want your object to be the mask for this environment. In the Render Settings simply enable Film > Transparent so that the environment texture is invisible for the camera. On your masking ...


3

This channel can be interpreted by the game engine as grayscale data and used for any purpose like a subsurface scattering map, which may be what is happening here. This is called Channel Packing. Reference: http://wiki.polycount.com/wiki/ChannelPacking


2

Replace anything you use in your Reindeer material with a Holdout shader: Now in the top-right corner, rename your view layer to reindeer, then create a new view layer, rename it to background, and in that new view layer, disable the collection containing the reindeer: Now go to the Compositing tab, and enable ✅ Use Nodes on the top bar. Duplicate the ...


5

If you render your object with a transparent background, yuor render will have an alpha output in which the object will be white and the background black. In the compositor you can use this output in the input of a "Set Alpha" node which carries the background image you want (a render of the background sky or directly the image of the sky).


2

When using transparency in EEVEE, make sure to set the material's Blend Mode to something other than Opaque. Alpha-Blend or Alpha Hashed should work fine. For some objects, you may also find things look better if you also enable Backface Culling:


1

The alpha channel needs to be associated to the image. Use an Alpha Convert node and choose Straight to Premultiplied.


2

By default the Material Preview mode will use a default HDRI (world image) and that's what is reflected on your object. To change that you can go into the Viewport Shading panel and check Scene World for example:


1

Welcome to Stackoverflow. Yes, your computer was hacked. You should immediately format your disk and throw your computer out of your window.... NOOOO!!! just kidding. Since you are a totally beginner to Blender maybe you should watch some basic tutorials. e.g. here: https://www.blender.org/support/tutorials/ What you see is just a special kind of display ...


2

Because you are using Repeat extrapolation in Image Node. Those pixels are just texture's pixels from opposite side of texture. Set Extend instead.


0

I got a same issue and found this question. The answer above works but a bit mess with many nodes, so I came out with a simpler solution. In the following example, having the mouth texture as the base, the eyes texture is put on top of it. Such overlay is done by Principled BSDF shader. Subsurface Color comes on top of Base Color, while applying alpha to the ...


3

Let's start with the very basics. What you call "transparent" is an Alpha Channel at work. The image you are creating has tree color channels (RGB) and a separate Alpha channel, that is used as a Mask to determine how the image is combined with others. This is what the Alpha Channel looks like: The alpha channel is nothing magic, it is just black ...


1

First, you need to do something with the alpha output of your texture. For example, plug it into the alpha input of your shader. (BTW: it seems that your PNG does contain an alpha channel...) Then, if you use EEVEE, you need to make sure that your material's blend mode is set to "alpha hashed" or "alpha blend". (See here: https://docs....


5

It will help to look at the values you're operating on. If you go to Edit -> Preferences -> Add-Ons and enable Node Wrangler you gain a lot of functionality and keyboard shortcuts in the node graph. We're only interested in one of those functions right now, though. You can Ctrl + Shift + Click something to link its outputs to a viewer node and just ...


9

This seems to be some form of crude "Wipe" effect. By using the object's local Z coordinate as input and running through the Less Than math function it basically makes an horizontal line mask. In the vector node the X and Y axis Scale value to zero is turned down, which makes it basically output the pure Z axis, as opposed to all axis at once which ...


Top 50 recent answers are included