New answers tagged

0

You must enter Edit Mode and select the entire object. Then UVs will appear in the Image Editor.


0

As in 3D view: M ⇾ By distance


2

You probably need a Texture Coordinate node in your material setting the Brick Texture node's Vector input to UV: Without that the Vector input's default is Generated:


4

If you have a lot of objects or data and speed is important: import bpy from bpy import context as C import numpy as np source = C.active_object targets = (o for o in C.selected_objects if o is not source) uvs = np.empty((2 * len(source.data.uv_layers[0].data), 1), "f") for o in targets: target_layers = o.data.uv_layers while ...


6

Select the target meshes (to which you want to copy the UV map), Shift-select the source mesh (that contains the UV maps) and run the following script in the text editor. import bpy context = bpy.context obj = context.active_object uv_layer_names = [uv.name for uv in obj.data.uv_layers] if uv_layer_names: for ob in context.selected_objects: if ...


0

In recent version of Blender, you can use an automatically generated UV Map. You can modify the map's coordinates in the Properties Editor's Curve Properties tab; in the Texture Space panel: Here is an example material where I just used the automatic map and a generated UV grid image: and here is sample curve: You can read more about Texture Space in the ...


2

Pinning will always keep the vertex at its absolute position. You don't need to "glue" these faces as they are already part of the same island. You can select all the islands you want to automatically position, then click UV > Pack Islands. If you want more resolution (more space in texture space) for a certain island. Simply select an island, ...


6

No, it's by design. UV coordinates are relative to image dimensions. So then you put an image with different aspect ratio, it distorts. But you are able to use different size variations of texture (for example 512x512, 1024x1024, 4096x4096, etc.), without changing UV. To fix your issue, you can redo UV set by selecting the orthogonal view and pressing U ⇾ ...


1

Your paint should be black&white ... ... and used as Factor for mixing shaders. Or you can create new texture with Alpha zero and paint directly by color ... ... and use Alpha channel as Factor for mixing shaders.


0

According to your screenshot your 3D viewport is in Object Mode, for what you're describing you want it to be in Edit Mode:


3

Here in Blender 2.79 and in BLender 2.93 actually Blender 2.8+ have different panel for UV editing And Image Editor, previous versions like 2.79 Used image editor menu for UVs see the marked icons in the image of blender 2.93, above one is image editor and below one is UV editor That's why you couldn't see ur uvs because the panel u have opened is Image ...


1

You can use noise texture in GN as well. To deform along normal, simply scale the normal vector by texture output. Subtract and multiply simulates mid-level and strength.


1

My advice is, instead of using one map for everything, you could use multiple UDIM tiles. This way the textures will be less grainy when viewed up close. It all depends up to what zoom the model will be displayed. Also you could subdivide the various meshes in the UV maps by material type (concrete, wood, glass, tile ceramics, etc...) or by object type (roof,...


8

In your Subdivision Surface advanced settings, choose UV Smooth > Keep Corners:


2

I suppose your problem is bad unwrapping. First select all in Edit mode, choose a front view and unwrap again with the Cylinder Projection mode: Make sure that you've enabled the Scale to Bounds option in the Operator box: You end up with that:


0

So, I understood the problem. Triangles that are included in the pillars have different position and when I baked AO, Substance Painter draw 8 different AO maps in the same place because I have overlapping, therefore I have one AO for different pillars that have different points of collision with triangles. Solution: refuse from overlapping or place ...


0

Press A to select everything and then press . on your numpad to "View Selected".


2

Looking at your blend file I see you have a lot of duplicated geometry, Merge by Distance removes 2240 verts. You also have a lot of faces with the Normals facing the wrong way -- in Edit mode click the Show Overlays drop-down and check the Face Orientation box to see them easily, then select some of the red faces and Mesh > Normals > Flip, continue ...


0

Okay, I found the okay solution myself. My way of doing things will suit you if blender is your hobby and you just want to render images with characters from the game, for example. The final model also could be rigged and looks just fine. If you are an experienced blender user (or it’s your work) - you may find my ways of doing things offensive. I’ve warned ...


0

You can try changing blend mode in material settings


3

Just tab into Edit mode and press A and press U and choose the unwrap option. Then select all your UVs by pressing A and pressing S to scale it. After I did that everything looked fine, there was no stretching. Your object has no issues it is perfect and has good geometry with perfectly marked seams. And also as moonboots said apply your scale by selecting ...


1

I'm going to go back a few steps to make sure I cover everything. The faces of the crate didn't line up when you rotate and mirror them because the object origin is in the wrong place. It so happens that the origin of the crate should be at world origin, so to fix this, snap the cursor to world origin with Ctrl + S then press 1. Then right click the crate ...


1

There doesn't seem to be a way of doing this automatically, unless someone makes a plugin. This is how I did it with external image manipulation programs. This is the current UV unwrap To save the image from Blender, open it in the UV Editor and press Shift+Alt+S to Save As. Then use an external image editor to crop the image. Note the factor you are ...


1

In Edit Mode, press U then click on Reset. In the UV Editor, scale all the reset UV's to the correct place on the image.


6

You should have indicated in your post that you send this to Substance Painter. The issue here is that, Substance Painter on a per-material basis. So each object sharing the same material will use the same maps. So, technically, your UV's from SP look like this: So you have to either arrange the UVs to make them fit the UV space without overlapping. Or you ...


1

Increase the Extrusion value and set the Maximum Ray Distance to 0


0

Thanks to moonboots for their comment. I looked into the UV editor and found that the scale was different. Don't know why or how this happened, but its an easy fix. Thanks again


0

When objects are joined, the resulting material slots is a set union of all material slots, where a slot is considered unique if it points to a unique material. So if you join a body and a head, each having 1 material slot, but they point to different materials, the resulting object will have 2 material slots, and the geometry of the 2nd object (the one ...


1

Baking is a rendering function, so in Cycles it's affected by the number of rendering samples. If you're baking a property which is not affected by lights (i.e. base color, without diffuse light, indirect light) you can turn down the samples even to 1, to speed up the process. Where lights and shadows matter (like Ambient Occlusion) you will need more ...


3

Currently there is no specific node to access UVMap coordinates inside Geometry Nodes, but you can use a Vector type input and set it as an Attribute instead of a single value, and then select the UVMap data from the face corners domain in the modifiers panel. Answer based on this youtube video.


1

One thing is (as you can see) UV Projection modifier generates smaller image in front side to closer camera and bigger image on opposite side due conical shape of projection from point - so distance of camera matters. In this case I would suggest to use Texture Coordinates > Object and use another object like Empty to control position. To position it ...


2

If your objective is simply to have a more detailed texture, then the relative sizes of your UV islands shouldn't matter - rather, the resolution of your image texture is important. You certainly can map your texture across multiple images like moonboots said, and each of those images can afford to be smaller while still maintaining a highly detailed whole, ...


4

I would try for face in bm.faces: # Compute edge vectors e1 = face.verts[1].co - face.verts[0].co e2 = face.verts[2].co - face.verts[1].co # Decide which is width and which is height if abs(e1.x) > abs(e1.z): w, h = e1.length, e2.length else: w, h = e2.length, e1.length # Assign UVs for loop in face.loops:...


2

Assuming that you have applied any rotation and scale to the planes, this code will divide the edges of the planes into those parallel to the X axis and those parallel to the Z axis. (Really, those not parallel to the X axis, but I'm assuming your planes meet your criteria.) If you have not applied rotation and scale, then you need to vector multiply the ...


1

your mesh is not flat which creates the lines. scale to 0 in the x axis to fix that. you unwrap from view to bounds stretches your image, use regular unwrap or unwrap from view. Here is an improved file: https://we.tl/t-JZUQj9axWt


0

as you can read here: https://docs.blender.org/manual/en/2.79/editors/uv_image/uv/editing/unwrapping/mapping_types.html Project from View (Bounds) With Bounds will do the same as Project from View but with Scale to Bounds and Correct Aspect activated. Which means it will "fit" your model into the image size. So you can either change your image ...


1

Maybe you should tell us what you want to do as an end result? you can mirror a texture with the help of shading nodes like this: so the "trick" is to just use negative scale values for a coordinate...


0

So, as @NeilAshleyHickman and @gatzkerob answer. Here is the way: Create material, then select Mix Shader in Surface section Set the first Shader to Transparent BSDF, and the second to Diffuse BSDF Click the right dot button in Color and select Image Texture, then select your transparent texture image. Goto Node Editor window (Shift + F3), and connect the ...


0

okay, this is actually fairly simple, its something I had trouble figuring out the beginning too. click on the object you want to texture. then hit tab and go into edit mode. on the menu on the right side. hit the texture button. hit new (if you don't have one on it yet) and then hit the + to add a second one. then hit "3" to only select the faces. ...


0

plug in a mapping node and a coordinates node set to UV. make sure your texture scale is not to large or to small in de mapping node.


0

Here’s what I think is going on: Although the two image data blocks are from the same file, they are not the same data block, so the only way to get them in sync right now is to save to the image file and then reload everything. What you need to do is go back to the shader and select the same image data block that is open in the image editor, by clicking the ...


1

If you construct your handlebars, at least initially, from the native (round) 'Bevel' of a curve,set in its Data tab > Geometry panel, you can use the same curve to deform the spiral of tape. If you make the spiral by using a Screw modifier on a single line of geometry, offset from its object origin, then the 'Stretch U' and 'Stretch V' settings in the ...


0

If you have enabled this add-on here: you can go to add mesh -> landscape Hit on Shading tab and add these nodes choose a texture with e.g. some text Hit on UV-Editing tab and select all vertices Choose UV -> Project from view Then you might get something like this, which you can "fix" with S -> to scale and G -> to move. In ...


1

Okay never mind I figured it out! Turns out it was because I had accidentally deleted the camera and it won't work without a camera in the scene.


0

I forgot that my object has "gutters" between each face. Therefore adding additional space between each face in my UV fixed the issue.


1

...If you forget the Empty, and, in Edit Mode, align the mesh: short-side up the Z of its own Object Axes (displayed in this illustration), and long-side along the X, then a 180 X-bend followed by a 360 Z-bend will work. Modifiers are in the modified object's space by default, so they stay aligned to the object when it is rotated,translated, or scaled.


2

It is because you have simple deform that blends your object around empty. Then you rotate the object empty stays in place, that makes changes in position of empty relative to object. As a result, object blends in the different way. You can parent empty to object (Ctrl+P) or apply modifiers to prevent this behavior. You can also use Add -> Mesh -> UV ...


1

Since you have removed faces with UV coordinates and added new faces without the UV, you are not able to see the texture, because where is no UV to map texture on faces. You need to recreate the UV map.


0

You have a couple of problems in your logic. Some are from the way you're mixing mesh ops with bmesh ops and some are in the way you're using bmesh. Bmesh requires that you validate the faces or edges lookup tables before you use the data with a line like this. Replace faces with edges for the edge data. bm.faces.ensure_lookup_table() As long as you're ...


0

You can use the "light path" node and connect the "is reflection ray" on the numbers material and plug it into a mix shader combined with a transparency shader. This way the numbers wont show up in reflections.


Top 50 recent answers are included