New answers tagged

1

For anybody that stumbles upon this later, to delete the vertex color go to Object Data Properties (Green upside down triangle) -> Vertex Colors (Click on it to open the drop down) -> Hit the minus button to remove the vertex color. (In my case it was something named Col)


2

Your model has a vertex color layer that is black everywhere but the hands. In glTF the first vertex color layer is always multiplied into the base color, so anywhere the vertex color is black, the base color will be black. You can check what happened by reimporting the .glb into Blender and comparing against your original material. Here's the nodes you'll ...


1

to export multiple animated objects with armatures, vertex groups should have unique names. here's a little script to rename bones and vertex groups based on parent armature name: import bpy for obj in bpy.context.selected_objects: if obj.type == "ARMATURE": prefix = obj.name + "_" for bone in obj.data.bones: ...


0

Putting the origin on the bottom of the object and aligning it to world origin before exporting solved the issue.


2

i used this base code to resolve this # 1 - Export data as JSON file # dict with all your data dict = { "description": "description", "external_url": "external_url", "image": "image", "name": "name", "attributes": [ "a", "b", &...


2

I wasn't sure if I should answer since it's mostly a Python question, but it has a few small Blender specific aspects... import bpy, json from pathlib import Path C = bpy.context # define what identifiers mean: shapes = { "AA1": "Sphere", "AA2": "Cylinder", "AA3": "Cube", "...


0

Andy, I hope you were able to find an easy, economical solution. I stumbled on your question 8 months later and wanted to share how I accomplished importing assemblies into Blender (while keeping parts separate) so that anyone else who finds this post later has at least one solution. I imported the STEP file into Rhino, selected all, and performed ...


1

I'm not sure if this could be solved entirely within Blender, but you would start by baking the Shadow on the plane to an image texture. I'm not sure how you would process the amount of shadow on the final image, but here is how you can Bake a shadow map: Create the scene as intended, attached is a recreation of your screenshot Select the Plane or whatever ...


3

In Edit Mode, Mesh > Separate > By Material (shortcut: P).


0

In summary, I just saved it within Blender, used its API to save, then removed the image. Here's my sample code: def execute(self, context): C = context.scene D = bpy.data movie_clip = D.movieclips[C.sm_src_mov] viewer_area = # ...get viewer area viewer_space = # ... get viewer space # ...get and set space and area def ...


2

All meshes in scene. Some Common methods seen in many answers, will look for links, but none AFAICT ask this specifically Using Sets. To get a list of all meshes in scene can use a set, which will keep the number of each to one. Set of all meshes in a scene meshes = set(o.data for o in scene.objects if o.type == 'MESH') or by name meshes = set(o.data.name ...


0

It's hard to tell without knowing what your objects and textures are and what their relation to each other happens to be for your specific object. However, I would assume that someone exported an object from blender as an .obj file and selected "export materials" so it generated a .mtl file. This mtl (material) file should be imported when you ...


0

In my case, there was something wrong with uv map, after unwraping it with Smart UV Project I could export to fbx BUT then there was something wrong with fbx itself. After unlinking all materials from object in outliner I was able to export valid fbx file.


0

True! Problem solved disabling CPU from CUDA selection (Intel Core i5 9400F - Nvidia Asus ROG Strix 1060 6GB) and seems faster too! Not sure why, but not complaining lol


0

Got it, found out the issues. Substance Painter does not like faces with more than 4 nodes. Correcting that fixed it up straight away.


0

1) Create a camera, and make it face the object? Tip: Shift A > Camera Tip: Go to Preferences > Keymap > 3D View | View Camera - assign hotkey, I use C. Tip: Go to Preferences > Keymap > 3D view | View Navigation(walk/fly) and assign a hotkey, I use alt, `. This will let you control the camera like it was a first person game (must be in view ...


0

rig it in blender then in the modifier tab of the properties window duplicate the armature modifier and apply as shape key you should only do this at the end once youre sure you have youre mesh the way you want it cause shape keys can be wierd


0

It is because you scale texture in nodes. It isn't supported in fbx file format. You should scale UV itself instead


Top 50 recent answers are included