New answers tagged

0

You only need one boolean modifier if you are using the same object for all the windows, so you can go to edit mode of the cutting object and just duplicate the windows and move them around as a mesh of a single object from edit mode.


0

Use the Array modifier on the window cube. Make sure to increase the relative distance to be greater than 1.0 otherwise, your cubes won't separate.


0

By default the mirror modifier will choose its mirroring axes depending on the object's origin, not the world origin. The origin of each object is marked by a yellow dot when it is selected. As you can see, your tooth's yellow dot is a little bit to the left of it, so logically the mirror modifier creates a copy with a symmetry relative to its that. If ...


1

By the way, in Blender 2.8, as you can not find "Removes Doubles" in menu, just go to Vertex > Merge vertices > By distance


0

Having done this for 3D printing before, I can admit it's an annoying problem. Admittedly, I did so through booleans, and that was a complicated process. Here is a workflow adapted to the bisect tool: Bisect Tool Method Join the objects as one. This will be necessary in any method. Bisect while in edit mode. Check the fill box to fill in the mesh where you ...


1

I just needed to put it on the Z axis, apply then rotate it. Found the answer on this video (at 3:45) while searching for a solution.


0

I've created a work around for my problem by removing the main control empty (along with my ability to move everything from a dynamic center) and replace its functionality with a driver that outputs half of the array's distance. This will allow me to use that drivers value to offset the start empty manually (though for my use case, I can still semi ...


5

In your preferences, make sure you enabled the "Import images as planes" add-on Go to Add (or SHIFT + A ) > Image > Images as Planes Then choose your video. Add your modifiers : Set some keyframes and play.


2

Subdivide the plane and you will be able to apply the modifiers.


1

You can parent both your object and the hooks to an empty, that would take care of the origin. You can also use the empty if you want to animate all the cubes relative to each other. However: I would strongly suggest you just use an armature with 3 bones and put one vertex to weight 1, and the other 2 to 0 for each according bone. Hooks are dangerous, ...


1

First of all, I suggest you work with a lot less subdivisions, and use Smooth shade to hide the hard edges (Right Click -> Shade Smooth). I reduced your number of subdivisions to 1 and the Boolean worked fine, you'll also need to apply the Mirror modifier first. Also, try changing the geometry of that concave section (the top part of the "cutter") as it's ...


1

Apply scale. Press Ctrl+A. Apply scale Now select the empty and rotate


0

I had this same problem. I don't know why it's happening to me, while others seem to do it without trouble, but I tried to change the interpolation mode to constant, and it worked. Go to: Editor type > Action editor right click > interpolation mode Let me know if it worked for you!


3

Three things to make it work. Your curve's radius is messing it up. Uncheck Radius in the Curve properties. The object and Curve origins need to match. Set the Object's location to X=0, Y=0 Your curve modifier is using the wrong axis, set it to X axis.


0

Select the curve,array and empty together by using shift +click to select multiple or simply use box select to select all of them and then move them wherever you want. I will surely work fine .


0

I figured it out! You have to press tab on the curve to go into edit mode, select all the points, then move it where you want it.


0

While the Mesh Deform modifier still doesn't work like it did in 2.79, (I've now submitted it as a bug) I was able to get a work around with Lattice. This actually works amazingly well. Thanks to Richard Lester for the solution.


2

One way is to use multiple loocuts. Set Pivot center to Individual Origins Scale and move the secondary loopcuts Use the Shear tool to adjust the rotation.


1

The particle system is based on faces of the boolean intersection between a very narrow cube and the mesh text. The problem occurs when that boolean operation is between letters, creating an empty mesh. The particle system still needs to produce particles at the rate declared (10000 over a few dozen frames) and thus default to producing those particles ...


2

As stated in the comments by Mr Zak and Robert Gützkow, you can select the objects you wish to remove all modifiers from, then select an object with no modifiers, hit CTRL+L, and link the modifiers. This will get rid of all of them on all of the objects.


0

Youn need to plug the "UV" output from the texture coordinate node, into the image texture node, instead of the "Object" output. If you are using a default sphere, it should already be UV unwrapped.


2

You could: Delete 'Faces only' the curve-shape, leaving a network of edges Knife Project the network down onto a plane Delete away unwanted parts of the plane X > Limited Dissolve unwanted edges (there may be some minor repair work to do) Extrude the result, which is then OK for a Boolean.


3

You have four boolean modifiers before your last bevel modifier. Those are notorious for creating funky meshes afterward, which is what is making your last bevel modifier go nuts. It's not working on clean geometry which is causing those artifacts. Before any bevel I would do the booleans and apply these modifiers and clean up the resulting mesh, then add ...


0

If you're using a modifier, the original object will remain. You can even move it around, and it will be joined in the new locations in real time. If you would like to get rid of the object, you can either hide it (so you can continue to modify it) or (and this is more likely for your use) apply the modifier, which will permanently fuse the objects. ...


3

The glitches are caused by overlapping vertices. The only solution is proper topology, supporting the bevel. If we examine the effect of the bevel modifier on your topology, we can see the vertices are badly positioned and the bevel quickly creates overlapping faces. Position your edges parallel to each other and assert that the edges have a minimum length....


1

Welcome to Blender Stack Exchange! There are a couple of things to try here. First, select everything in edit mode and press ShiftN to recalculate the normals. Sometimes Blender gets the direction the vertices are facing confused, and this causes issue with beveling. Second, try and get rid of the 'ngons', aka faces with more than 4 vertices. Beveling ...


2

So, I read this question and try it myself, after lot of trials and errors, I found the settings that I think get close to the video are: Curve type: 2D, give it extrude value of 0.01m Remesh modifier with Sharp mode, Octree Depth: 5, Scale: 0.6, and Sharpness: 0.1 Shrinkwrap modifier with Offset of 0.01m This one is optional, but I think this is what they ...


1

You need to make sure that the particle system is placed last in the modifier stack (the bottom most one) : And also check "Use modifier stack" in the source panel of the particle settings :


2

The reason there's no error in the displacement in EEVEE is that there is no displacement in EEVEE. So, if you like what you see there, the simplest solution is to unplug the displacement. But that's not an explanation of what's happening. If a vector is plugged straight into the Displacement input of a Material Output node without going through a ...


3

Add a cube, then apply an array modifier in each dimension, and finally separate each part. import bpy bpy.ops.mesh.primitive_cube_add(enter_editmode=False, location=(0, 0, 0)) cube = bpy.context.selected_objects[0] for i in range(3): mod = cube.modifiers.new('Array', 'ARRAY') mod.relative_offset_displace[0] = 0 mod.relative_offset_displace[...


0

The problem is duplicated vertex, removing them will probably fix this issue. If you are a beginner, in Blender 2.8+ to remove doubles right click in the viewport while in Edit Mode, with all of your vertex selected. Hover on Merge and select Merge by Distance. In older versions do the same thing but don't right click. Instead press W to open the ...


0

Boolean isn't good for 3D printing at all, it often creates a lot of errors. Iam using multiple objects, joint them and after Iam done I use voxel remesh, which makes it one object in topology and solid.


0

Okay so I found one way to fix this Duplicate one of the two offending meshes Apply remesh to the new duplicate Separate a part of the mesh that included the offending vertices from the newly remeshed mesh Delete the offending vertices and vertices that overlay with the new piece from the old mesh Stitch together the old mesh and the newly remeshed part ...


3

Looks originally like "Normal" problem. this post will give you an idea about it. it happens a lot when models are extruded. Blender How to Recalculate Normals


1

Fixed by deleting the faces and adding them again.


3

You need to duplicate the objects in Object Mode and join them. Duplicating them in Edit Mode gives weird results. Duplicated in Object mode and joined. Works as expected. Duplicated in Edit Mode. Gives weird results.


2

You have to create custom Operator class and register it. Inside the operator you have to check if the object has the modifier or not. If it is not then add or else remove it. Then replace the YourOperator.bl_idname with "object.modifier_add". Added shade smooth and flat toggle. For shortcut you can click on the button and "add shortcut". Note: Your ...


0

It might be because the vertices in the mesh are not made properly positioned that the blender is not able to properly calculate how to apply the modifier. So try these: Recalculate the normals properly using: "Shift+N" Go to edit mode and remove duplicate vertices by "Merge by distance option" (make sure you set the proper distance in the dropdown menu). ...


0

I have figured it out! In this case, the object that is generated from a boolean operation should go through a triangulation.


0

I believe based on the comments, that you should be able to do the following. It may get slower, but let's try: Make a copy of the surface you have Add a solidify modifier to the copy and set the modifier up like this: The thickness can be small, as we only need one extra (the lower) loop going around to produce the thickness. If you apply the modifiers ...


0

Add modifier using API, override the modifier apply. Would use m = ob.modifiers.new(name="Foo", type='DECIMATE') m.ratio = decimate to add a modifier, and override the context of modifier apply operator, just as you have done for material link remove. bpy.ops.object.modifier_apply({"object" : ob}, apply_as='DATA', modifier=m.name) Questionable whether ...


3

You can do this by using a lattice to proxy the shrinkwrap modifier. Add a lattice at the same position as where you want your objects to intersect. Add a shrinkwrap modifier set to your cylinder. Add a lattice modifier to your array sources : https://www.youtube.com/watch?v=tsNPpFvpTAU https://youtu.be/UfhJ0mBUqr8


0

Dissolve those faces that are overlapping, select them and the ones you want them to connect to and press Ctrl + E --> Bridge Edge Loops to fill them.


3

Use Dupliverts Result using icosphere as "seed" Organic yet accurate modeling with the golden spiral @Rekov Hi, Thank you for your response. While it does answer the question on how to create the spiral, it does not show how to create the spiral out of the objects which currently exist in the scene collection. To clarify, I have modeled a "seed" ...


1

Once your surface is subdivided with sufficiently small faces, you can use Mesh Tools -> Deform: Randomize to add roughness. Fine-tune using the tool parameters shown below. My result: If you prefer to have bumps instead of spikes, you can again Mesh Tools -> Add: Subdivide (with four or five cuts) and select Smoothness = 1.


0

Its because how the mesh is shaped as it contains ngons so if you would add subsurf modifier it would create weird geometry try creating a good mesh without tris and ngons just with quads. Here I've converted ngons to tris and quads by selecting all the ngons and Hit Ctrl+T in Edit Mode. Then ngons will be converted to tris and quads. Then by bevel edges ...


1

You have to set the falloff type from sphere to projected.


1

A simple way to do that is to use a 'simple deform modifier' and its 'taper' function.


0

To do it you should pin the sail to e.g. empties put at the corner vertices thereof. You should have the pin option in the cloth sim menu. EDIT: Set sail's vertex weight to 1 after you applied the curve modifier.


0

Was about to post this question I had stored as a draft since yesterday and just now I found out the answer. The mirror modifier doesn't create vertex groups, it only flips them from left to right to the according ones of the other side. To be able to mirror the vertex groups your mesh should already have the groups, named accordingly (Whatevs.L and Whatevs....


Top 50 recent answers are included