8

In the default keymap it’s Shift + Numpad. To align a view to an object’s local axis without Shift, tick the 'Align Active' option in Preferences → Keymap → 3D View → View Axis


3

The 3D view is currently in wireframe mode (1). Click on the white globe (2) to select solid view or press Z and select Solid from the Pie menu.


3

You can catch the left-click event when the button is pressed to differentiate between UI and hotkey call, using event.type == 'LEFTMOUSE': https://docs.blender.org/api/current/bpy.types.Event.html#bpy.types.Event.type import bpy # https://blender.stackexchange.com/a/24002/ class OBJECT_OT_CustomOp(bpy.types.Operator): """Tooltip"&...


2

You need to open the Nvidia control panel and disable the overlay. Steps from a web search Right click on the Nvidia system tray icon and select NVIDIA GeForce Experience. Log into your NVIDIA account. Click the Settings icon (gear) on top right. In the GENERAL tab, turn off IN-GAME OVERLAY and exit.


2

See what letter of the primitive is underlined, for example the P of Plane is underlined.


2

You can also add a (hidden) property, IE Bool or Enum to the operator (as you already do) which will be set when the button is pressed. https://docs.blender.org/api/current/bpy.types.KeyMapItem.html#bpy.types.KeyMapItem.properties import bpy # https://blender.stackexchange.com/a/24002/ class OBJECT_OT_CustomOp(bpy.types.Operator): """...


1

If you go into Edit > Preferences, then go to the Keymap tab on the left, at the top you have some presets. One of them is called Industry Standard or something to that effect. Do these defaults match your preferences? If not, from this menu you can go in and manually change them all by searching for your function in the search bar (Zoom, Orbit etc.) then ...


1

go to preferences -> keymap -> key-binding and search for "+". Looks like you have something else referenced to same key. If this doesn't work, please provide screenshots of your search result for "mesh":


1

The problem wasn't related to Blender per se but more an action that you frequently do in Blender. When you hit Alt + Shift under Windows operating systems it will change your keyboards layout. You can turn this off by toggling a setting in windows. It is explained in this post: https://superuser.com/questions/698037/can-i-disable-the-altshift-shortcut-to-...


Only top voted, non community-wiki answers of a minimum length are eligible