I'm having a small issue with visible seams on normal maps. The map was painted on Substance Painter and has no weirdness around seams. When I plug it into a Normal Map node set to Tangent Space this happens:

tangent normal space (it's a horse underside)

When I set the map to Blender Object Space the seams become nearly invisible, as they should be, but the shadows also looks awful.

blender object space

What can be done to minimize the issue? I need to be able to use maps on tangent space. Moving the seams or hiding them under other stuff isn't always feasible.


2 Answers 2


Substance offers two options for normal maps, DirectX and OpenGl. DirectX is the default (normally set when you first setup a project). The difference between the two is that the green channel is inverted from one to the other. Blender expects normal maps in the OpenGl format.

There should be options in Substance Painter to export with the OpenGl format instead.

You may need to look at export presets to do this: https://support.allegorithmic.com/documentation/display/SPDOC/Creating+export+presets

Otherwise invert the green channel of the normal map using a RGB Curves or Invert node:

enter image description here

Related: DirectX vs. OpenGL normal maps

  • $\begingroup$ Of course! And there I was sitting and wondering if there wasn't some hidden issue with the UV. Now it looks perfect! An alternate solution for people who might face the same issue and can't re export the maps right away is inverting the green channel directly on Blender: i.imgur.com/euyU5Iy.jpg $\endgroup$
    – Rhaenys
    Oct 30, 2017 at 10:04

I was getting this issue with both DirectX and OpenGl Normals and came here to look for a solution- however, I found a fix: In the image map node for your normal, change the sRGB colour space to non-color.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .