0
$\begingroup$

I have been using blender for a bit and ran into some weird issues when using Normal maps from Substance Painter and have no idea why.

Sketchfab

Sketchfab In software such as Sketchfab they show up perfectly fine with no visible deformations in the model

Blender Blender But in Blender the normal maps makes it look skewed and not flat per say. Here are the nodes that I use with blender

Blender Nodes

And here are the export settings in Substance Painter if it helps

Substance Export

The normal map that I export from Substance Painter is in OpenGL format. I use Blender version 2.79 and have had the same issue with Blender Eevee.

Otherwise is there a specific node setup that we should use in order to get the same results that we see in Substance painter?

Thank you for your time.

Edit 1: Here's all the Texture maps used

$\endgroup$

2 Answers 2

1
$\begingroup$

The likely cause is differences in triangulation.
You'll notice that your baked normal maps aren't "flat" - they compensate for averaged normals of low-poly triangulated geometry. Assuming the base normal map was baked in Substance Painter, this now means that the original non-triangulated mesh in Blender is "out of date", as Blender triangulates it differently.

In Painter, you can File > Export Mesh, load this triangulated mesh into Blender and try the same material on it. Alternatively, you could have added a Triangulate modifier to your object before exporting and baking, ensuring consistency across different software.

A less general solution is marking some sharp edges and unticking Average normals when baking. The resulting normal map would then be made to be applied to a flat surface, so the triangulation would no longer matter.

In an upcoming Blender version you'll be able to "spin" the "virtual edges" inside a face without doing triangulation explicitly, but that's hardly a solution.

$\endgroup$
0
$\begingroup$

Unfortunately, we can't see your image texture nodes, which makes me think you don't know there is an important setting there, that you need to set up properly depending on the kind of map you're using. But as I can't see, maybe it's not the answer either.

As explained in the Blender Manual - Image Texture Node: You have to set the color space to "non-color data" when your texture doesn't output color info for your material. Normal maps must be set as non-color data (as well as metallic, specular and roughness).

If you're curious on understanding the difference between "color" and "non-solor data" color spaces and why use one or the other, I suggest you read this topic.

$\endgroup$
2
  • $\begingroup$ My bad, I have uploaded a picture of the expanded nodes and I did use non-color data before in the node setup. $\endgroup$ Nov 28, 2018 at 14:52
  • 2
    $\begingroup$ My only reference is that: jtheninja.wordpress.com/2017/05/11/substance-and-blender-2-79 Otherwise, I have no idea where is the issue. Maybe tweak the strength. That being said, there is no way you can obtain the same result from different render engines. $\endgroup$
    – L0Lock
    Nov 29, 2018 at 9:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .