2
$\begingroup$

So i was rendering models from games in Cycles and in some cases the shading looks terrible, shadows are very blocky and there are visible normal map seams. I increased the size of the lamp and tried different lamp types but it had no effect. Adding geometry isn't an option because a subsurf-modifier would cause undesirable deformations in some places. The model came with normal, specular, bump and glow maps which are currently plugged in the Principled shader; shading is set to smooth. Can this problem be fixed or is Cycles not suitable for assets like this?

Example: enter image description here

Edit: node-setup: enter image description here

$\endgroup$
  • $\begingroup$ "assets like this" assets like which? Did you try changing space for the normal map? (Object, Tangent) What is the Cycles material setup? $\endgroup$ – Mr Zak Nov 4 '17 at 19:48
  • $\begingroup$ Combine normal and bump by plugging Normal output from the Normal map node into Normal input of the Bump map node and connecting that to shader. I also don't quite get the meaning in Emission shader adding to the material half by half but maybe it won't cause those artifacts (still try detaching and see what happens) $\endgroup$ – Mr Zak Nov 4 '17 at 21:59
  • $\begingroup$ Thanks, that makes much more sense. The emission shader is mixed in at .5 because the glow map is black. Setting it higher causes everything to turn black (except the glowy parts). It looks good the way it is and doesn't seem to cause any problems. $\endgroup$ – MasterBates Nov 4 '17 at 22:13
  • $\begingroup$ Does blender.stackexchange.com/questions/93398/… help with the normal map? $\endgroup$ – Sazerac Nov 6 '17 at 4:42
  • $\begingroup$ No, i already tried that, but the problem still persists. $\endgroup$ – MasterBates Nov 10 '17 at 15:54
0
$\begingroup$

That looks like a UV mapping issue, perhaps with lighting baked into the texture. Try temporarily removing the textures and see if it looks any better.

$\endgroup$
  • $\begingroup$ I justed checked. The only way to avoid the problem is by removing the normal map, which removes a great amount of detail. Again, this is a professionally made asset from a game. It must have to do with Cycles/lighting. $\endgroup$ – MasterBates Nov 4 '17 at 19:42
  • $\begingroup$ If you look at the normal map texture, does it have lighting and shadows in it already? $\endgroup$ – SilverWolf - Reinstate Monica Nov 4 '17 at 19:43
  • $\begingroup$ I suppose. This is the normal map: imgur.com/ez9Z0Dx $\endgroup$ – MasterBates Nov 4 '17 at 19:51
  • $\begingroup$ Oh, it's one of those RGB ones. (: Baked lighting probably isn't the problem, then—try adjusting the amount the normal map affects the material. $\endgroup$ – SilverWolf - Reinstate Monica Nov 4 '17 at 19:53
  • 3
    $\begingroup$ @MasterBates Just to be safe pls post your material nodes (can you update the question?), what you did shouldn't be necessary. There might be another catch to it.. $\endgroup$ – Jaroslav Jerryno Novotny Nov 4 '17 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.