2
$\begingroup$

I made this model in Blender and Textured it in Substance Painter. While in Substance I didnt see any problems, but when exporting it to Blender and applying the maps i got weird artifacts and color problems. I used Blender 2.8, I have good specs (so no performace issue), and the newest version of substance painter. I have not changed any settings in blender - they are all on the standard setting & I rendered with eevee. In Substance Painter I chose the Unity Setting for Baking. Without Normal Map: enter image description here With Normal Map: enter image description here Material in Blender: enter image description here Normal Map: enter image description here

In Sketchfab it works, altough i get pretty visible seams there. Maybe someone also knows a solution to that: https://sketchfab.com/models/9a6ee7b916b34d358621eae53d6d89a4

Thank you for helping me!

$\endgroup$
  • $\begingroup$ Please don't add external links to images as they can be taken down. There is an option to add images to your questions. Also try to be as clearly as pssible when posting a question, ad some additional information as to what settings you are using and possible system specs, sofware versions etc.(screenshots wil help a lot) $\endgroup$ – Delagone Jan 7 at 7:16
  • $\begingroup$ This seems like a problem I also been having trouble with ever since I started to use blender. It always occurs when using normal maps generated from external software. A workaround that I found usefull is to change the strength in the normal map node to something lower like 0.1 or 0.2. Also it's important to change the image texture from color to non-color. (try this first) $\endgroup$ – Delagone Jan 7 at 7:29
  • $\begingroup$ @Delagone ive tried all that already. when lowering the strenghts im losing to much detail, i tried non color-data. thanks for your help, but that sadly didnt fix it. $\endgroup$ – Erik x Jan 7 at 7:31
2
$\begingroup$

You may be experiencing issues because of different normal map types. DirectX and OpenGL normal maps differ in the green channel. It is inverted. To convert one type to another you would need to invert the green channel of the map. This can be done with nodes inside Blender:

enter image description here

$\endgroup$
0
$\begingroup$

I found a quick fix, but i would rather want a real explanations why it doesnt work. i added the normal value now directly to the output node at displacement, instead of putting it into the prnicipled shader. now i dont have the artifact

$\endgroup$

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.