1
$\begingroup$

I am trying to bevel a curve by selecting it in orange, but only one section will apply the bevel modifier,

enter image description here

I am using Blender 3.0

Any help would be greatly appreciated.

Thanks,

UPDATE

Here's the file.

http://shanegibney.com/shanegibney/dart.blend1

The reference images

enter image description here

enter image description here

enter image description here

$\endgroup$
9
  • $\begingroup$ hello please share your mesh $\endgroup$
    – moonboots
    Jun 24, 2022 at 14:19
  • 1
    $\begingroup$ I suppose you have some doubled geometry, try selecting whole mesh and pressing M → By Distance. $\endgroup$
    – Crantisz
    Jun 24, 2022 at 14:22
  • $\begingroup$ How do I know I have double geometry? I went into object mode and clicked on the shape, I don't know if I am clicking on the object or the mesh and hitting 'm' It highlighted in orange. But no change unfortunately . Thanks for looking at this. $\endgroup$
    – ofey
    Jun 24, 2022 at 15:14
  • $\begingroup$ You click on the object in Object mode, and on the mesh in Edit mode. $\endgroup$
    – FFeller
    Jun 24, 2022 at 15:48
  • $\begingroup$ OK got it hanks. Unfortunately the m in object mode doesn't seem to do anything. $\endgroup$
    – ofey
    Jun 24, 2022 at 16:30

1 Answer 1

2
$\begingroup$

I see now. It is a combination of several issues.

First one. Is a doubled geometry, as I've deducted yet:

enter image description here

It is easy to remove. Select all vertices by pressing A in Edit Mode Then press M → By Distance

But that's not all.

Second issue. You have set limit by angle. 90 degrees is very unstable, some angle may be less than 90 some more 90 because of precision error. So set it to 89 for example.

But even that is not all.

After that, your bevel will be limited by minimal edge. In your case, that edge:

enter image description here

You have to decide what to do with that. Move edge or remove it, or live as it is.

$\endgroup$
2
  • $\begingroup$ It seems there are three points. 1. There is double geometry as you suggested. This can be removed by going into edit mode and pressing m and selecting by distance. All done. 2. Setting the limit by angle. It should be less than 90. I've played with this doesn't seem to work. 3.Bevel limited by edge. I Wish to keep the edge. But how do I do this? The gifs are great for expalining. Thanks for your help. $\endgroup$
    – ofey
    Jun 25, 2022 at 6:58
  • $\begingroup$ 2. It will work if other problems are solved 3. You can allow overlapping in bevel modifier, but in this case, faces will... overlap :-) $\endgroup$
    – Crantisz
    Jun 25, 2022 at 8:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .