3
$\begingroup$

I'm trying to combine an edge bevel with a vertex bevel using the bevel modifier. I've watched numerous videos about hard surface modelling but all the different options are confusing me. I thought if I could tackle one problem at a time it might all start to make sense.

So, referring to the image, I'd like to apply an edge bevel (1) and a vertex bevel (2). With both bevels applied the edge bevel is being clamped (3) and I'm seeing some unwanted artifacts on the corners. If I uncheck the Clamp Overlap, I get the expected result (4) - not good !

I don't really understand what it does, but I've got the Auto Smooth turned on at it's default value of 30%. Again, I don't really understand what it does but I've tried tweaking the Harden Normals settings and that doesn't help either.

Any help would be greatly appreciated, and any explanation that makes this clearer for me would also be a huge help.

Many Thanks

enter image description here

$\endgroup$
2
$\begingroup$

This is because the second bevel is trying to bevel edges which shouldn't be beveled, creating too much geometry, thus creating the artifacts.

You will see that if you set the limit method in the second bevel to "Angle" and then progressively increase the angle, at some point the artifacts will disappear. Notice how the vertices count in the lower right corner drops while you increase the angle limit. Alternatively you can set the view to wireframe (SHIFT + Z) in order to see exactly which edges are beveled.

The angle refers to the angle between the two face connected by the edge, 180° being coplanar faces, 90° being faces at a right angle and 0° being faces that intersect each other (also coplanar).

No limit Vs Angle limit = 21° :

With no limit

Angle Limit

$\endgroup$
  • $\begingroup$ Thanks Nathan, that's a great explanation and it's really helped clarify what's going on with the artifacts. I've spent a while playing around with these settings but unfortunately I'm still not able to increase the edge bevel to the desired size. The only way I can find to do this is by decreasing the number of segments for the vertex bevel but then the corners look awful. I'll keep experimenting - maybe in this particular case it's not possible to get the result I want without making detailed edits to the mesh. $\endgroup$ – Marcus Jan 14 at 13:19
  • $\begingroup$ Yes indeed, every time you add a bevel segment to the vertex bevel, the edge bevel gets thinner. Consider checking the "harden normals" on the modifiers to have crisper shading without needing to add more geometry $\endgroup$ – Gorgious Jan 14 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.