1
$\begingroup$

This question already has an answer here:

I want to set a camera so what the camera sees is exactly what I see in the viewport.

I know that Ctrl+Alt+Numpad0 will move the camera to my 3D Viewport location, but it also severely crops the sides and sometimes does not show all geometry.

3D Viewport:

viewport

Camera view after pressing Ctrl+Alt+Numpad0:

camera

Hitting Ctrl+Alt+Numpad0 crops the camera view, zooms out, and clips off the plane in the background.

How do I make it so that hitting Ctrl+Alt+Numpad0 actually sets the camera view to the 3D Viewport view, without distorting it, clipping geometry, or otherwise altering the view?

$\endgroup$

marked as duplicate by David Jan 4 '16 at 0:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1
$\begingroup$

Just use Ctrl + Alt + Numpad0 and then move the camera back on the Local Z axis (double tap Z for local). You may also want to adjust your clipping on your camera. To do that go to the camera settings in the property panel and move the end distance back until everything is there, i.e. not clipped...

$\endgroup$
  • $\begingroup$ Why is the camera so zoomed in, though? How can I set it so that it does not zoom in/crop by default? $\endgroup$ – Somatic Jan 3 '16 at 22:59
  • $\begingroup$ I don't know, its not that hard to just move the camera back though. You could try using fly mode, I think its called that anyway, just use Shift + F then use the wasd keys to move and the mouse to rotate $\endgroup$ – mr-matt Jan 3 '16 at 23:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.