Pressing Ctrl Alt NumPad 0 causes the camera to teleport over and align itself to the current view in the 3D viewport.
However, it usually takes up only a small portion of the view, meaning that you have to move the camera back to fit the same view you had before. Is there a way to set the camera view to fill more of the 3D viewport when using this feature?

  • $\begingroup$ Do you mean that the camera is zoomed further in than you expected or that the camera has a large dark border surrounding it when in camera view? $\endgroup$ Commented Apr 24, 2014 at 14:59
  • $\begingroup$ Kinda both. David's answer below does what I was wanting. The camera zoom can be adjusted to match the viewport zoom by lowering the Focal Length from the Camera tab in the Properties Editor. My goal was to be able to move my viewport view, then snap the camera to match that view without having to adjust anything else. This I can now do now that I know that the zoom amount when in NUMPAD 0 camera view is remembered after leaving that view. $\endgroup$
    – JosiahJack
    Commented Apr 25, 2014 at 0:13

4 Answers 4


First hit NumPad 0 to enter camera view, then press Home so the camera fills the window. (On laptops or smaller keyboards: View ‣ Cameras ‣ Active Camera to switch to the camera view, and then View ‣ Cameras ‣ Frame Camera Bounds to get the FoV to fill the viewport.)

Now when you press Ctrl Alt NumPad 0 (View ‣ Align View ‣ Align Active Camera to View, or go to the camera view any other way) the camera will fill the screen.

If the camera is still not positing where you want it, then that means you are in Orthographic view. Hit NumPad 5 (View ‣ Perspective/Orthographic) to switch to perspective view, and the camera will match your view.

  • 8
    $\begingroup$ To make the camera view fit the window press Home $\endgroup$
    – user1853
    Commented Sep 19, 2015 at 15:49
  • $\begingroup$ @cegaton excellent tip, will edit answer now. $\endgroup$
    – David
    Commented Sep 19, 2015 at 15:52
  • $\begingroup$ is there an option for those of us without a numpad? $\endgroup$
    – jozxyqk
    Commented Jul 23, 2022 at 3:02
  • $\begingroup$ @jozxyqk From the Blender manual, the Home key is a shortcut for the submenu option View ‣ Cameras ‣ Frame Camera Bounds. $\endgroup$
    – Phrogz
    Commented Jan 20, 2023 at 16:55

After hitting CtrlAltNumpad 0 (and being disappointed by a cropped version of what you were expecting), select the camera (in the outliner panel), press G, then press the middle mouse button and move your mouse towards you. This will allow you to zoom out the camera little by moving the camera back in the correct direction.

When you are happy with the position, press the left mouse button or hit Enter to accept the change.

You can also pan and rotate the camera from this view without having to mess about with the camera object itself. See Dolly in the blender docs.

For a beginner the behaviour of CtrlAltNumpad 0 is really frustrating. It's a "feature" which IMO should be changed to take the camera focal length and the size of the current view into account.


Just select the object you want to view through and needs to be fit in the camera frame. Then go to View menu > Align View > Align Active Camera to Selected

Your object is full in camera view and can be rendered in full.

  • 1
    $\begingroup$ This does not solve the problem that the question is referring to: "Align Active Camera to Selected" does not mean that the camera view will match the viewport. $\endgroup$
    – Stabledog
    Commented Mar 26, 2019 at 0:09
  • 1
    $\begingroup$ I dont have Numpad, so this was helpfull. first clicking "Align to Viewport" and then "Align to Selected" from the same dropdown menu $\endgroup$
    – jamland
    Commented Dec 22, 2019 at 18:29

enter image description here

and make sure the check the lock "camera to view" box on the right.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .