0
$\begingroup$

I'm new to blender and am having issues rendering my final image. I have already used ctrl + alt +numpad0 to get the right camera position and angle. But when I hit F12, the render result does not match the camera view.camera view. I have tried several things and my render results just keeps coming up as completely different. I don't think I have any key frames, and everything should be on the right layer? I just wish to render a still frame, no animation.

render view, not done rendering

UPDATE: Render finished and the output is still completely different from my viewport and camera. enter image description here

Even using viewport render does not workenter image description here

Blender file is here

$\endgroup$
2
  • $\begingroup$ Hi. The second image (render output) shows only 8 tiles. It's hard to tell if the view of the render really matches the camera's view or if there are objects missing/not rendered. The estimated time of over 8 hours for the whole image is very long for the simple looking shading. You can reduce the number of samples (see Sampling -> Render on the first image) from 128 to 4 to do a quick check of what is actually rendered. $\endgroup$ – Blunder Oct 15 '20 at 10:21
  • $\begingroup$ Hi, update includes final render. I have even tried to use the viewport render and the output is just that grey image. $\endgroup$ – jmacnocheese26 Oct 17 '20 at 3:20
0
$\begingroup$

Your objects scale and clipping start and end are all off. But that didn't help. I did get a render that matched if you just apply the cloth and subdivision surface. Even leaving everything else alone.

$\endgroup$
2
  • $\begingroup$ Hi, I thought I did apply them. i have tried selecting and unselecting my cloth and subdivision surfaces, but that causes the cloth to fall our of place. $\endgroup$ – jmacnocheese26 Oct 17 '20 at 7:02
  • $\begingroup$ Sorry, yes nevermind, I see. Thank you! $\endgroup$ – jmacnocheese26 Oct 17 '20 at 7:13
2
$\begingroup$

The "real" cause of the issue, is the subdivision modifier:

enter image description here

As the subdivision levels does not match in viewport and render, the cloth cash is not valid when rendering.

Turn the *render subdivision levels" to 1 and that will be ok.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.