0
$\begingroup$

I made a separate object to model feet apart from the base mesh before joining it, making it one mesh. I then filled in all the faces between the two and as I did this I found that the smooth shading of the base mesh was interacting strangely with the joined mesh.

How do I fix this shading issue or is it a case of blender interacting with the model weirdly and its fine to export as is.

Close up

Full screen

$\endgroup$
7
  • $\begingroup$ Check for duplicate vertex there, there could be vertex fighting for dominance. $\endgroup$ Apr 4, 2022 at 2:22
  • 1
    $\begingroup$ You deserve that for writing in all caps $\endgroup$
    – WhatAMesh
    Apr 4, 2022 at 4:01
  • $\begingroup$ Theres no vert double ups and all caps scares people into answering my question. So maybe I do deserve it $\endgroup$ Apr 4, 2022 at 4:23
  • $\begingroup$ Select all in Edit mode and press Shift N in order to recalculate the normals? $\endgroup$
    – moonboots
    Apr 4, 2022 at 5:41
  • $\begingroup$ @moonboots that was it thankyou so much. I've had this issue a lot so much appriciated $\endgroup$ Apr 4, 2022 at 5:43

1 Answer 1

0
$\begingroup$

The normals are inverted (you can check if you enable the Face Orientation option in the Viewport Overlays, inverted faces will be displayed red instead of blue). Select all in Edit mode and press ShiftN in order to recalculate the normals.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged .