34
$\begingroup$

While rendering a mesh with smooth shading on, I get a dark region/shadow on certain faces. The effect is more evident when smooth shading is applied to a mesh containing ngons, with the ngons turning black when rendered.

The blackening effect is visible in the viewport too.

How can I solve this problem?

$\endgroup$
  • 8
    $\begingroup$ If one of these answers solved your problem, don't forget to click the "Solved" checkmark to let everyone know the question has been solved. :) $\endgroup$ – Thom Blair III Apr 18 '14 at 3:12
  • $\begingroup$ Let me reiterate one more time since you were online in Nov. Could you accept the answer that solves your problem? $\endgroup$ – Sibbs Gambling Dec 28 '16 at 0:32
47
$\begingroup$

Check your normals. If some of the facess are turned inside out, pointing inward into the inside of the mesh, they can be seen as dark areas.

Before recalculate normals (in the toolbar (N) in the 3D View, or CtrlN):

Faulty normals

After recalculate normals.

Corrected normals

Note that normals will only be recalculated for selected faces, so you probably want to select all (A) before recalculating.

$\endgroup$
29
$\begingroup$

Face Normals

In Blender, each face has 2 sides: one is considered the outside and one is considered the inside. The Face Normal indicates the outside face.

Blender displays faces differently depending on whether or not the normal is facing the viewer.

If you want to view your normals, you can open the Properties panel (N) and in the Mesh Display section, click on the Face Normals button:

enter image description here

(NOTE: Vertices also have Normals. You can view those by clicking on the Vertex Normal button here)

You can then flip normals of selected faces while in Edit mode by:
3D Viewport Header -> Mesh -> Faces -> Flip Normals

Or, if you want to quickly fix all the normals in your mesh, while in Edit mode you can use Recalculate Normals:

  • 3D Viewport Header -> Mesh -> Normals -> Recalculate Outside (CTRLN)

  • 3D Viewport Header -> Mesh -> Normals -> Recalculate Inside (SHIFTCTRLN)

$\endgroup$
-3
$\begingroup$

Sometimes an extrusion goes weird, meaning, it has that dark blue/grey color in such a case, select the culprit faces and go to the "Shading/UVs" tab in your toolbox, you enter your toolbox by pressing "T" once there, find the option that says "Flip direction" and that should give you the lighter colored base material of everything else. if not.... I apologize, I guess this isn't the problem I frequently encounter.

$\endgroup$
  • 2
    $\begingroup$ This answer does not provide any new information, it's vague ("goes weird") and also lacks necessary information. If a question already has good answers, please don't answer them unless you have really new and important information. $\endgroup$ – metaphor_set May 16 at 22:39
  • 1
    $\begingroup$ I also think this answer is not useful and vague. $\endgroup$ – Martin Z May 17 at 7:01

protected by cegaton May 24 at 2:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.