1
$\begingroup$

I am stumbling my with through a project using blender. What I'm trying to do right now is have my Scene (which I've added to the Video Sequence Editor, along with a video clip) to be displayed above the video.

So far, so good. But now I want to get fancy. My Scene basically consists of silhouettes. Because sometimes the video is black or very dark, I want to put a glow around the whole rendered scene (i.e. all the non-transparent parts).

I tried using the Glow effect strip on my scene, but that seemed to wipe out the transparency of the scene -- the video stopped showing through. I might be missing some easy way to make this approach work.

But now I'm trying to put together some Nodes to accomplish this effect. And it's really almost working, it seems like... My nodes to create a glow around my scene

But when I render a frame, I get... Rendered frame... a lot that should be transparent isn't?

(Glow exaggerated for clarity.)

I'm a newbie. I've been feeling around in the dark to try to make this work. Any help would be greatly appreciated!

$\endgroup$
1
$\begingroup$

The only way I could do it was to produce two separate movies/images. One for the black obects, the other for the white objects which are blurred when mixed in the compositor.

Here are the nodes...

One thing to check is your Render output; Open the "Post Processing" tab, make sure PNG format is selected, and also set it's RGBA box to on. (highlited) to ensure the Alpha Layer is included in the render.

Note that a separate folder for the output png files, (one for each frame) is a good idea.

The rendered pic I got was as we see in the backdrop above, complete with an alpha layer and ready to overlay another pic or movie as required.

If you're stuck I can attach the Blend file...

ADDENDUM: Here's how my output looks when overlaying an image or movie -

The mixing/scaling can also be done in Blender's 3D window. I tried that and the result was the same.

The Blend file follows and will open up in the 3D window which holds instructions on how to recover the two images needed for the compositor.

$\endgroup$
  • $\begingroup$ Hi, thank you for your answer! I will try out this method, but I just want to check -- my main issue is that when I go to the Video Sequence Editor, and Render a frame of my project, the transparency is wrong. The video shows through behind the glow, as it should... but everywhere else that should be transparent, it renders white. Does your setup avoid that? In some ways it looks kinda similar to the nodes I came up with. $\endgroup$ – David Newberry Oct 16 '17 at 1:24
  • $\begingroup$ Please see the addendum tacked on to the original answer. $\endgroup$ – Edgel3D Oct 16 '17 at 2:10
  • $\begingroup$ Thank you again. If you wouldn't mind uploading your blender file, I would like to look at it. I think I might have accidentally changed some setting, because I don't see why my project is having this issue... it seems like basically the same approach, to me. If you feel like checking it out my project, I uploaded it: drive.google.com/file/d/0B-Kc_OtJ1-4qZVlqbGJpa1hIRzQ/… $\endgroup$ – David Newberry Oct 16 '17 at 3:42
  • $\begingroup$ I got the same result as you and after trying several combinations gave up and used two separate images instead, made from the same Blend file so they'd be identical but with opposite colour. I'll pack those images into the Blend file and drop it at the end of the answer. $\endgroup$ – Edgel3D Oct 16 '17 at 23:45
1
$\begingroup$

I just couldn't give up on the method and after some more tinkering I stumbled on a solution. I wish I could say I understand the solution, but I don't really.

I added an "Alpha Convert" node just before the final output: Additional node I had to add to setup in original question

I was tinkering and changed the Premul value in the Alpha Over node, but it didn't seem to make a difference. Neither did what mode the Alpha Convert node used (Straight -> Premul or vice versa).

P.S. Thank you to Edgel3D for putting in the time to help me and put together an example for me and everything. I would have used that method if I hadn't gotten this to work.

$\endgroup$
  • 2
    $\begingroup$ Premultiplied means adding the background color into your alpha calculation. Blender should not use this but the VSE does, so you have to fix it with that node. $\endgroup$ – 3pointedit Oct 18 '17 at 4:42
  • 1
    $\begingroup$ Good one David. I've filed that one and have learned something. $\endgroup$ – Edgel3D Oct 18 '17 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.