3
$\begingroup$

I'm an absolute novice with Blender, and video editing in general.

I have a lot of 1 minute long videos taken by an older D-Link security camera of a long test inside an environmental chamber of a new product that my company is developing. I'd like to concatenate several hours worth of those videos into a single video that is easier to scrub through with VLC (or other video player) to better understand the workings of this product. I tried using Windows Video Editor and that program just chokes on the quantity of files.

I looked into VLC and it seems from the tutorials that I've seen that I would need to build a command line argument that includes all the source videos as a final step. But the number of videos makes that problematic. So, some further searching I decided to give Blender a try.

I was able to figure out with some online tutorials how to load all the videos into a timeline and then render to a single video file. I was able to do one set of 87 videos. But, I'm not really happy with the results so I think I may be doing something wrong. I'm getting a sideways swipe between each of the videos. I want to edit each video such that the first frame of the next video is rendered right after the last frame of the previous video without any fancy wipes or transitions.

When I select menu : Add/Movie in the sequencer window here are my import settings with all the videos that I want selected:

Add Movie strip

Then when I render I get the wipes between each video. I don't understand the terminologies used in Blender, so please teach my what I'm looking for and how to remove the wipes? Is there a way to do that to all the transitions between videos at once so I don't have to painstakingly apply the change to all the videos? Set some sort of movie strip import default?

I've created some files and several screenshots. To start, the environment that I'm working in is:

Edition Windows 10 Enterprise
Version 20H2
Installed on    ‎2021-‎08-‎12
OS build    19042.1526
Experience  Windows Feature Experience Pack 120.2212.4170.0

On this computer I downloaded and installed the latest Blender as of a couple days ago (specifically 2022-02-22, yes... "2's day"):

enter image description here

As far as I know this is the first time Blender has been installed on this computer so there shouldn't be any zombie settings. I did not go into the program preferences so to my best knowledge Blender should be working in "out-of-the-box" defaults.

So, when I start blender, I click on "Video Editing" from the splash window:

Blender Splash

Then in the sequencer sub window I select menu : Add/Movie

Add movie menu item

I browse to the path were the source video clips are stored, select all with the "A" key, and change the import settings on the right to Fit Method => Use Original Size and turned off sound because I'm not interested in any recorded sound.

Add movie strip dialog

Then in the sequencer I select menu: Strip/Menu Strip/Set Render Size to change Blender's default 1080p output size to the size of my video clips (720p). I discovered this trick when looking through the menus to try to solve my issue on my own.

Set render size

I then look at the strip time properties tab and manually copy the number to the render end frame number. (Is there a way to automate this with a menu item that I haven't found yet? I was looking for something like Set render range to sequence range or similar language.)

Strip properties Render Range

I set the rendering output filename and verify that the default output properties are acceptable.

Render output properties

And finally, I start the render.

Start rendering

The resulting video has a wipe (I'm not sure what this type of wipe is called) in between each source video clip where the new clip pushes the previous clip to the left. Stepping through the resulting video frame by frame there are 6 frames where the wipe goes about half-way across the screen before the new source video clip snaps to full screen. Here is the 2nd frame of the first transition:

enter image description here

I don't want that wipe, but I don't know what it is called so I can't find it in Blender. Here are a bunch of files:

$\endgroup$
15
  • $\begingroup$ "I apologize can't share any of the videos (even a small subset) because of the proprietary information" -> sorry, but everybody can provide videos which are "free". example: download from internet. Create your own via Blender. ....and so on. So please don't hide behind your own laziness. And "normally" the video editor doesn't add wipes automatically". $\endgroup$
    – Chris
    Feb 23 at 6:13
  • 2
    $\begingroup$ What @Chris means is that, you don't need to share your blender file with those exact footage, you can reproduce the problem with a minimal file with other footages that you can share (just 2 footage so one can see the transition) and then upload the file. $\endgroup$ Feb 23 at 6:15
  • 3
    $\begingroup$ Wrong Tool, IMO : This kind of bulk concatenation sounds more like a job for ffmpeg in a shell, than any video editor... see, for example, here $\endgroup$ Feb 23 at 7:10
  • 1
    $\begingroup$ Don't know what you are doing, but when I import a selection of videos into the sequencer, I'll get just the videos one after another without any swipe or other transition by default... $\endgroup$ Feb 23 at 7:44
  • 2
    $\begingroup$ If you only need to concatenate videos, why not use ffmpeg? $\endgroup$ Feb 23 at 13:22

1 Answer 1

1
$\begingroup$

With provided sources I didn't get your wipe effect.

  • Your render contains 27 error frames of wipe
    (I haven't seen such issue before :) )
  • Frame rate is correct (30) and end of the strip is fine as well

In my render I see differences in Blender versions.

  • Blender 2.8x - 7 black frames at the end of the first video strip
    (frames 1798-1804) ... also in between others (output as movie or PNG sequence).
  • Blender 3.1 - is fine (without any glitch or black frame) for MP4, MOV or PNG output.

... even in both Blender versions are mentioned frames empty in Video Editor > Preview.

So ... the only one conclussion I have is AVI codec issue?

Tips:

  • Try View > Refresh All (and Rebuild Proxy)
  • Since your strips are arranged one after the other, your blend mode type Cross has no effect, but since you deal with some issue here try to change something like Replace or Alpha Over if does it take soem effect in your case.
$\endgroup$
1
  • 1
    $\begingroup$ First I tried View > Refresh All but couldn't find Rebuild Proxy. I don't know if refresh did anything (no status indicators of anything being done was displayed). Rendering still showed a swipe. I then changed blend mode to "Replace" and it then rendered without any wipes. Looks like changing the blend mode fixed this issue on my machine. Thanx all for the help, and if this looks like a bug (and someone can actually replicate the issue) feel free to use my data as a sample for the bug report. Please make a copy as I may delete the files from my dropbox at a random point in the future. $\endgroup$
    – Sembazuru
    Feb 28 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.