1
$\begingroup$

This is really strange - but perhaps it's just a setting somewhere.

I'm using Blender 2.78c

I've created a scene with video+sound (let's call it sourcescene)

I'm using this scene as a scene-strip in another scene (let's call it targetscene).

Now when I start playback - an extra instance of the sound from sourcescene is started.

If I start playback from targetscene - the audio is played from whereever the playhead is in target AND from the beginning of source. If I stop playback, the part that played from the playhead-position stops (as expected) - but the extra part played from the beginning of source continues - and there is no way (that I can find) to stop it.

If I start playback from the sourcescene, the audio is doubled. When I stop playback, the double continues playing w. no apparent way of ending it until I restart playback in the sourcescene. When I restart playback the current "ghost"-audio stops, but the playback get's a new and playing "ghost"-audio

Recap:

Play from target-scene:

Audio from sourcescene is played from frame 0 together with audio from target-scene - no apparent way to stop it

Play from source-scene:

Audio is doubled. No way to stop the doubling. When stopping playback - the double contintues. When restarting playback, the double stops, but another starts (from the same spot as the playback was started) and the audio is again doubled.

What is up here - is this a bug, or did I miss some setting somewhere?

$\endgroup$
  • $\begingroup$ Not a VSE user myself but sounds like a bug. $\endgroup$ – Duarte Farrajota Ramos Mar 18 '17 at 0:07
  • 1
    $\begingroup$ Suggest making a test blend demonstrating above problem. $\endgroup$ – batFINGER Mar 18 '17 at 13:24
2
$\begingroup$

The answer is with AV-sync.

If you have multiple scenes with audio, then make sure that only the one you're currently working on is set to AV-sync.

If you do happen to get a sound instance running that is not apparantly attached to a scene, you can stop it by switching to the scene with AV-sync and start/stop playback once from there, that will stop the "wild" sound instance.

Here's a little script-snippet that will turn off sync on all scenes, then set AV-Sync for this scene only (tested with blender 2.7x - not with 2.8)

import bpy

for scn in bpy.data.scenes:
    scn.sync_mode = 'NONE'`

bpy.context.scene.sync_mode = 'AUDIO_SYNC'
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.