0
$\begingroup$

I have the problem that my blender hasn't updated correctly and is stuck on version 2.78 while it says that it has version 2.79, the issue is that I'm missing nodes like image textures and diffuse BSDF and the whole shaders option in the 'Add node' menu.

$\endgroup$
  • 4
    $\begingroup$ What exactly do you mean by "nodes un-updated"? What specifically is wrong? $\endgroup$ – Ray Mairlot Oct 7 '17 at 11:31
  • $\begingroup$ The 41000hz is unrelated and regular behavior, could you explain the issue better, what is wrong with your nodes? Have you tried clearing user data and preferences between installs? Try the standalone zipped install instead. Current version is 2.79 not 1.79 $\endgroup$ – Duarte Farrajota Ramos Oct 7 '17 at 13:46
  • 1
    $\begingroup$ As stated above the sound issue is not something that will stop blender from working correctly. To solve it read this link $\endgroup$ – cegaton Oct 7 '17 at 15:56
  • 3
    $\begingroup$ As for the missing nodes, are you sure you are looking into the materials and not into compositing in the node editor? blender.stackexchange.com/questions/61013/… also make sure you are using cycles and not blender render: blender.stackexchange.com/questions/6831/… $\endgroup$ – cegaton Oct 7 '17 at 16:34
  • 3
    $\begingroup$ What does this have to do with updating blender to make you think your blender version is 'stuck'? Nodes should be largely the same in both versions. $\endgroup$ – Ray Mairlot Oct 7 '17 at 16:53
3
$\begingroup$

There are three possible causes;

  • 1- The render engine might set to Blender Render (also known as Blender Internal) instead of Cycles. Materials work very differently in each of the render engines, and are not interchangeable.

    enter image description here

    Blender internal does not use shaders, Cycles does.

    enter image description here

    enter image description here

    To learn more about the difference between render engines read:How is Cycles different from Blender Internal? and Cycles vs internal vs game engine

  • 2- The node editor might be set to a different mode.

    There are three different modes for the node editor and they use different kinds of nodes.

    enter image description here

    By default the node editor is configured for compositing enter image description here.

    Change to the Material node editor (and make sure that the Use Nodes box is enabled).

    enter image description here:

    enter image description here

    More info:

    https://www.blender.org/manual/editors/node_editor/introduction.html#node-tree-types

    https://www.blender.org/manual/editors/node_editor/editor.html

  • 3- If Cycles is not available in the render engine list, then it needs to be enabled in the System Preferences>Addon List (Access the system Preferences window by pressing CtrlAltU)

    Look for the Cycles Addon in the render section, enable it using the check box and then save the user settings to enable cycles permanently.

    enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.