8
$\begingroup$

I have Win 10 and when I open Blender I have the error:

AL lib: UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead

$\endgroup$
  • 1
    $\begingroup$ I have the same "error" don't worry about it. blender will work fine. $\endgroup$ – David Apr 16 '17 at 16:07
8
$\begingroup$

While this is a harmless error, this is how you can fix it:

enter image description here

$\endgroup$
  • $\begingroup$ The sound settings are 48000 kHz! $\endgroup$ – user38158 Apr 16 '17 at 16:37
  • $\begingroup$ ... and Blender don't work. $\endgroup$ – user38158 Apr 16 '17 at 16:45
  • $\begingroup$ Nice! I never knew (or cared) how to fix that message. So simple. Now the question is why does blender default to 44100? $\endgroup$ – David Apr 16 '17 at 17:21
  • 2
    $\begingroup$ @David - 44100 is the sampling rate used for audio cd, 48000 is the newer standard used in professional audio recording as it "works" better with multiple frame rates. When blender added audio, 44100 was probably picked as the most commonly used rate at the time and no-one has bothered to change it. $\endgroup$ – sambler Apr 17 '17 at 2:31
  • 1
    $\begingroup$ So Blender crashes on startup and the solution is to open it and change it's settings?! $\endgroup$ – Menefee Dec 24 '18 at 15:35
3
$\begingroup$

To fix this issue you just do like in pictures In priorities sound and set to 44100 Hz then ok and run blender , that all enter image description here

$\endgroup$
  • $\begingroup$ This is the solution to the problem. My device, a Dell soundbar, was set for DVD quality (48000 Hz); setting it to CD quality (44100 Hz) solved the problem. imgur.com/a/Szv11 $\endgroup$ – Sabuncu Dec 21 '17 at 11:20
  • $\begingroup$ Instead of changing the system to fit Blender, why not change the Blender settings to match the system? I did and no startup error now after saving Save to Startup File. $\endgroup$ – ejbytes Sep 5 '18 at 7:43
  • $\begingroup$ @ejbytes that would be ideal but blender doesn't open for me because of this error so that is impossible to do $\endgroup$ – Assimilater Aug 14 at 19:21
0
$\begingroup$

Now, I have changed the GPU from NVIDIA high-performance processor to Integrated graphics (default). Blender works fine now.

$\endgroup$
0
$\begingroup$

enter image description here

search sound in search box. Open it. Double click on the audio device you are using now. Then another properties box will pop up. Go to advance settings. See 2 pics with white background in my case. Now open blender user preference. Go to system settings. Make sample rate and sample format same as the properties box which pops up previously. In my case see the pic... 48 khz and 24 bit signed.. Then apply settings.. Then reopen the blender app.. The problem will be solved.

$\endgroup$
  • 1
    $\begingroup$ Use taking screenshots instead of photos way and organize windows so that one doesn't overlap another.. $\endgroup$ – Mr Zak Jul 10 '17 at 18:02
0
$\begingroup$

Windows 10: Log out and back in again, and Blender will start working again. (This is a solution to many (non-Blender) problems on Win10.)

I was getting the AL Lib:Update message on running a second instance of Blender. Pressed Ctrl-Alt-U, Blender crashed immediately. Could no longer run even a first instance of it.

$\endgroup$

protected by cegaton May 5 '18 at 8:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?