0
$\begingroup$

I am trying to bake a sound to an F-curve as input to a Shader node. I follow the suggestions here and here, but still I cannot make it work. I can add a keyframe to a value node, open the Graph Editor, and select the keyframe. But nothing like "Bake sound to F-curve" shows in the context menu:

screenshot of missing "bake sound to f-curve"

Here are the menu items I see under Channel:

Delete Channels
---
Group Channels
Ungroup Channels
---
Toggle Channel Setting
Enable Channel Setting
Disable Channel Setting
---
Toggle Channel Editability
Extrapolation Mode
---
Hide Selected Curves
Hide Unselected Curves
Reveal Curves
---
Expand Channels
Collapse Channels
---
Move...
---
Revive Disabled F-Curves

I am using Blender 3.3.2, and here is a link to the Blender file.

How can I make bake a sound to an F-curve if that option in the context menu is missing?

$\endgroup$
2
  • 1
    $\begingroup$ Please use the search function. Does this answer your question? Where is Bake sound to F-curve in 4.0? $\endgroup$ Nov 20, 2023 at 15:07
  • 1
    $\begingroup$ Oh, you are using an older version... in previous versions before 3.6 it can be found in the Key menu, not the Channel menu. If you are follwoing a tutorial, make sure the version there is the same as yours, some things change between versions. $\endgroup$ Nov 20, 2023 at 15:12

1 Answer 1

2
$\begingroup$

In Blender versions 3.5 and earlier Bake Sound to F-Curves is located in the Key menu of the Graph Editor:

3.5 and older

In version 3.6 it changed to the Channel menu:

3.6

In the new version 4.0 it is still in the Channel menu, but now it is called Sound to Samples:

4.0

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .