5
$\begingroup$

I am making a house in Blender Cycles. In rendered mode, all shaders are somehow visible, even though I don't use any lamps. I do have an environment texture, however it shouldn't light up the inside of the house. Especially when there are no windows. Even if I set the background strength to 0, it still lights up the inside and outside of the house.

So now, if I add any lamps, I has nearly no impact on shadows, shaders, reflections etc. What could be wrong with my scene?

Let me know if you have any questions on my settings that might help you find the problem.

File: https://www.mediafire.com/?cs3dl1xx56ih60a

These are the world settings: enter image description here

For the Ambient occlusion I always use this node: enter image description here

It usually works fine.

$\endgroup$
  • $\begingroup$ As far as I know, only lamps, environment textures and meshes with a material that uses an Emission shader can add light to a scene. Can you post a .blend? $\endgroup$ – Lewis Mar 3 '17 at 13:43
  • $\begingroup$ yea sure, moment.... $\endgroup$ – Hendriks3D Mar 3 '17 at 13:44
  • $\begingroup$ Possibly Ambient Occlusion. $\endgroup$ – Leander Mar 3 '17 at 13:46
  • $\begingroup$ It'll take a while, I use Mediafire to upload because the file is more than 30Mb. $\endgroup$ – Hendriks3D Mar 3 '17 at 13:49
  • 1
    $\begingroup$ This might be overstepping a little bit (as a more accurate approach would be to go check out some of Troy_s 's info on colorspace - Adrew Price over at Blender Guru did a pretty good breakdown of how to breakdown his work for getting started with it in Blender), but for photoreal - colorspace reasons, AO can be used to mimic the washing out of colors, instead of just upping their brightness when hit with light. If you would rather be more accurate check out the youtube video $\endgroup$ – Rick Riggs Mar 3 '17 at 21:31
14
$\begingroup$

Objects may appear illuminated, if ...

  • they are illuminated by lamp objects
  • they are illuminated by mesh lights with emission shaders
  • they are emitting light completely or partially, if they have an emission shader
  • the wrongheaded use of an Add Shader in a material
  • they are illuminated by the world (background shader)
  • ambient occlusion is activated

The Ambient Occlusion is activated in your scene.
enter image description here
Uncheck Ambient Occlusion to disable it.
It is found under the World section of the Properties Panel.

Also make sure no light emitting objects are hidden by pressing AltH to unhide all objects.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I didn't completely turn off the AO because there is a bit of an outside scene as well. I do want clear shadows there with the environment texture. $\endgroup$ – Hendriks3D Mar 4 '17 at 0:47
  • 1
    $\begingroup$ Nice answer. You might want to add that Add Shaders can also cause illumination. Here is an example .blend of a "light" created with only Add Shaders chained to a standard Diffuse. $\endgroup$ – Mentalist Mar 4 '17 at 2:19
  • $\begingroup$ @Mentalist Great example. Will add, thanks for reminding me. $\endgroup$ – Leander Mar 4 '17 at 9:14
0
$\begingroup$

This link solved it for me: Had the same Problem. Light in the scene even though I had no lights placed.

How do I turn off environment/world lighting in Blender Cycles?

Go to World Tab. Then to Surface option. Then pick use nodes.

Then you can see Background written on the button that appears. Or you choose Background under the shaders that appear when you click your the option under Surface.

So you pick Background as the shader of your Surface option. And then comes the trick, you click it again.

And then as the shader you can choose: Remove. That solved it for me. Under the link is a video that shows it.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.