3
$\begingroup$

While testing out a lighting setup for archiviz in Blender Render I encountered a strange problem. The ceiling is too dark no matter what I try.

The ceiling appears significantly darker than the neighboring walls, and the rest of the room

Here are some things I tried:

  • Checked that normals are facing the right directions
  • Removed all modifiers from ceiling plane object
  • Joined ceiling and room as a seamless mesh
  • Tweaked all lighting settings I could think of
  • Tweaked all material settings I could think of
  • Extruded the ceiling plane to give it a volume

Things to note: The only light sources are a duplivert array of Point Lamps and the ambient light from outside the room. I tried other types of lamps such as Spot and Area, but settled on Point because I found that the shadows looked best with Point. The other lamp types still didn't brighten the ceiling enough, except when I created a dedicated secondary Area Lamp pointed upward at the ceiling - which caused lighting problems in other parts of the room because the undersides of furniture would glow.

I made a special material for the ceiling that is like the rest of the room, except with some emission to brighten it. It looks better with that on than the regular room material, but doesn't look good because it kills the shadows in the corners. And besides, it's a hack and doesn't solve the real problem.

What could possibly make a ceiling appear darker than the walls it touches?

$\endgroup$
  • $\begingroup$ I've tried your setup, but lowered Lamps on Z axis to 2.85. Looks better. Screenshot: imgur.com/a/TAjhn $\endgroup$ – Serge L Aug 30 '17 at 7:10
  • $\begingroup$ @SergeL Thanks for taking a stab at it! The center of the ceiling looks good, but where the walls meet the ceiling it's still dark. I think the root cause of the problem still persists. $\endgroup$ – Mentalist Aug 30 '17 at 8:39
1
$\begingroup$

Well your using Blender internal and not cycles so its not perfectly light emulation. Here are the steps to make it a bit better, first decrease the strength of those lamps

( set it to 0.001 or so, there is way to much light in the scene currently).

in the world tab:

  • enable Ambiant Occlusion
  • enable indirect lightning
  • set Gather to Approximate

there are some more problems (placing of lights etc) but above should give you a start for this file.

$\endgroup$
  • $\begingroup$ Thank you!! So it seems maybe having too much light energy can (counter to expectation) cause extreme shadow contrast? I'm starting to understand how to strike a balance between the approximated Indirect Lighting which prevents the room from getting too dark in the corners (but kills a lot of the shadows that give objects their shape), and the Point Lamps's ray shadows that create nice detail on objects, but require a certain amount of light energy to do this, approaching the dark corners problem. I'm still fine-tuning and experimenting, but yes, your answer gave me the start I needed. Cheers. $\endgroup$ – Mentalist Aug 30 '17 at 12:49
  • $\begingroup$ Here's the improved .blend, in case you're curious to see. $\endgroup$ – Mentalist Aug 30 '17 at 13:31
  • $\begingroup$ Looks nice, i think you hould tryout Cycles render engine $\endgroup$ – user3800527 Aug 30 '17 at 14:01
  • $\begingroup$ Thanks. I mostly use Cycles actually. That's why there are some areas of BI that I'm unfamiliar with. But the render time needs to be as quick as possible for this project, and also I'm looking for a clean, almost illustrated look with this, not photorealism. $\endgroup$ – Mentalist Aug 30 '17 at 14:09
  • $\begingroup$ otherwise you could render it all once, bake it all (shadows) and do camera path trough it in almost realtime BI or viewport render $\endgroup$ – user3800527 Aug 30 '17 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.