1
$\begingroup$

I have an animation where I use the graph editor for animate the flickering effect of neon litghts inside a garage. I used cylinders with emission shader for the neons tubes and area light for lighting the scene. I did that because if I use only emission shader with high emission value I get to much noise, so I can use only area lights but if this are inside the glass of the lamps I get less noise but still too much, If I use only area lights positioned outside of the glass I get almost no noise but it looks not realistic because I don't have the detail of neon lights inside the glass. I'm rendering with low samples and branched path tracing, where the all neons are switched on I can get really good results (almost not noise and good details) with really low time rendering.

For the flickering effect I used graph editor with noise modifier on both (emission shader objects and area lights), by adding this I have two main problem:

1- Even if all the modifier settings values are the same, except for the strenght of light areas and the emission shaders value that have different values (for get less noise from the emission shader I setted it to just 10, for lighting well the scene I setted 40W the strenght value of area lights), at some frames I get the area light already switched on and the neon cylinders still switched off. I played with the offset value of the noise modifier but if I fix one frame I broke another one.

enter image description here

2- Using noise modifier on the curves in some frames it reach negative value and this seems literaly absorbing lights from the ambient (I'm using Cycles), if I compared rendered frames where the light is exactly 0 the scene look dark but still lighted, on frames where it reach negatives values I get a completly dark patch. I tried to change the blend type from "replace" to "add" and this don't let curves to reach negatives value but I get a completly different effect, they not seems like neons flickering but like soft lamps, in less words the interpoletions seems too softer.

negatives values reached

values exactly at zero

$\endgroup$
2
  • $\begingroup$ Lights in cycles will accept a negative value and will absorb light from your scene. $\endgroup$ – Allen Simpson Dec 3 '20 at 1:24
  • $\begingroup$ So how can I fix this problem? Should I don’t use noise modifier and try to replicate it by settings intermediate key frames? $\endgroup$ – GGKMNTN Dec 3 '20 at 1:39
2
$\begingroup$

You can add a Limits modifier to clamp the output to any range you want.

The limits modifier can be added from the N panel in the graph editor.

enter image description here

$\endgroup$
2
  • $\begingroup$ Perfect! Do you knoe how can I fix the problem that i get in some frames the area light already switched on and the neons cylinder with emission shader still switched off? $\endgroup$ – GGKMNTN Dec 3 '20 at 12:20
  • $\begingroup$ I'm sure you can but I kinda stumbled upon this answer. $\endgroup$ – Allen Simpson Dec 4 '20 at 2:13
0
$\begingroup$

You can use limit modifier after the noise modifier to prevent negative values

Also,you should use emmision and use the denoising data of cycles to later add a denoise node in the compositer,so you will get image with almost no noise with low sample rates

$\endgroup$
5
  • $\begingroup$ For more information- docs.blender.org/manual/en/latest/compositing/types/filter/… $\endgroup$ – Raj jaiswal Dec 3 '20 at 3:37
  • $\begingroup$ Thanks for your answer, for future reference, additional information should be added to your answer as an edit rather than as a comment. :) $\endgroup$ – Timaroberts Dec 3 '20 at 3:45
  • $\begingroup$ I tried to use node denoiser but on this forum they suggest me to avoid it and use instead a video denoiser... with emission shader only It was really too much noised, with area light I have less then 1/4 amount of noise... evene at 2000 samples I acnt' get the same result with area lights $\endgroup$ – GGKMNTN Dec 3 '20 at 12:15
  • $\begingroup$ In some cases, denoising node makes artifact's but in others it works just fine,if you're having trouble using denoise node,don't use it otherwise,give it a try $\endgroup$ – Raj jaiswal Dec 3 '20 at 13:19
  • $\begingroup$ A pro tip is that you should use denoise node and then use mix RGB node to blend between denoised image and noisy image with the factor input $\endgroup$ – Raj jaiswal Dec 3 '20 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.