3
$\begingroup$

I have set up 3 spot lamps and a sun lamp to illuminate an interior. I have never used Cycles lighting before and I'm new to Cycles in general. I have played with the strength, size, and rotation of all the lamps but the lighting is always the same. It is highly diffuse, no shadows. The only thing that changes the lighting is the Ambient Occlusion fields in the World section of the Properties editor. If I uncheck that, everything goes black.

I am looking to give the setting natural indoor lighting, but the sky is black because it is the Moon, so World > Surface > Color is set to black. The sun filters down between very tall beams and through glass. It should cast the shadows of the beams, it is lined up to do so, but no shadows. The three spot lamps are intended to show the light filtering in from light tubes, but there is no sign of the lamps.

I imagine there is some basic thing I have done wrong. How do I correct this?

Edit: Objects with Emission shaders do work as lamps (I just tried it). So I could simply switch the lamps over to that, although that isn't going to help for the sun. I had understood that now most lamps work in Cycles, except for the Hemi lamp.

lunar settlement interior

$\endgroup$
  • 1
    $\begingroup$ Here's a question that may clarify some points: Meaning of Sun Lamp Size (what it is said is true also for the Spot lamp). In addition some lamps are "outside" the interior and the sun light is being scattered away by the thick glass roof. The lamps work, you just have to make their light reach the scene. $\endgroup$ – Carlo Aug 2 '16 at 22:10
  • $\begingroup$ @Carlo I am aware of the effect of lamp size, but thanks. I just tried putting one of the spot lamps up to strength of 1 000 000, and it is quite dim. I tried the sun at 100 and it still has almost no effect. The glass is thick but it is transparent, i can accept that some light is reflected off, but not that it is invisible. $\endgroup$ – kim holder Aug 2 '16 at 22:17
  • $\begingroup$ Also note that objects with emission shaders work as one would expect. $\endgroup$ – kim holder Aug 2 '16 at 22:19
  • $\begingroup$ Interesting scene btw. Is it for a movie? $\endgroup$ – metaphor_set Aug 3 '16 at 0:05
  • $\begingroup$ @metaphor_set it is the beginning of a virtual lunar colony. Moonwards $\endgroup$ – kim holder Aug 3 '16 at 0:23
3
$\begingroup$

To get some light through glass you need to modify the default glass shader as it will not let direct light go through (see this answer)

enter image description here

Change the glass material to something like this:

enter image description here

Then the sunlight will go through the glass:

enter image description here

Then you have at least one light that is outside of the object. Move it so that the light is not obstructed by the object.

enter image description here

$\endgroup$
2
$\begingroup$

The issues pointed out in the answers by cegaton and eromod were part of the solution. There were some other elements to the issue though, and so I am adding another answer.

Even with the position of the spot lamps fixed, two of which had unwittingly been moved outside the wall (xp), ambient occlusion was completely overwhelming the light from them when set at strength of 5000. Strength of 50,000 was enough, but didn't give the effect I was going for, of sunlight emerging from a light tube, unless blended completely to 1, widened to 90o, and bounced the maximum number of times. With ambient occlusion set to 0.1 that then looked fairly natural.

The glass didn't let light pass until it was set up with the node tree cegaton explained, but even then it was very dim set at 50. My guess is that because the World background is set to black, because it is the Moon and there is no atmosphere, the sun has to be set far higher than normal in this situation. 300 was about right. But although that setting was good inside, when looking at the exterior landscape, sun that bright was way too much, washing everything out to pure white. So, I faked the sun indoors with a rectangular area lamp that I made very long and narrow, just underneath and running the length of the stone arches and glass roof, set at 12000. It isn't quite right but it is fairly close. The sun outside is set at 15. It doesn't look at all realistic there as the materials setup is still pretty simplistic, but the light levels are about right. This way I can bake the lighting into the objects in the scene so I can upload it to Sketchfab with good lighting and better materials.

lighting of lunar habitat

$\endgroup$
-1
$\begingroup$

Its the size of the lamps enter image description here

you can use light portals They work best when most of the light in your scene comes indirectly from the environment through small windows.

And here are some examples of professional lighting rig setups.

$\endgroup$
  • $\begingroup$ This isn't an issue of how to light the scene best, though. The lamps aren't working. $\endgroup$ – kim holder Aug 2 '16 at 21:41
  • $\begingroup$ maybe its a problem with the materials, were they created in blender internal? blender.stackexchange.com/questions/364/… $\endgroup$ – eromod Aug 2 '16 at 22:01
  • $\begingroup$ Yes, they were, but they have all been converted to Cycles nodes. $\endgroup$ – kim holder Aug 2 '16 at 22:03
  • $\begingroup$ looks like its being lit by ambient occlusion but if I turn that off, everything goes dark, odd $\endgroup$ – eromod Aug 2 '16 at 22:08
  • $\begingroup$ btw, i added some info to the question - emissive objects work as expected, only the lamps don't work. Yeah - that was exactly the thing i noticed. $\endgroup$ – kim holder Aug 2 '16 at 22:09
-3
$\begingroup$

It's actually a very simple fix. Turn ambient Occlusion off completely and then put in your lights. That's it.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.