2
$\begingroup$

ver 2.76-rc2 Win64

I'm trying to create a small landscape from 2 screenshots (of a game) that is in total 256 px x 176 px. Nothing too fancy all that's really different in terms of elevation is a pond. Grand total of 3 height changes. White for ground, slightly darker white (lol) for shallow water, and black for the pond)
Height Map

I import image as plane, subdivide it to the max (A blender tutorial I found said to do 300 but for some reason it only goes up to 100), then add a displacement modified and assign the image itself as the texture. For some reason it doesn't import the whole image so I change the texture coordinates to "UV" and the whole image is imported properly.

Now for the actual problem:

By default (I assume) for some stupid reason, the borders are 1 pixel more than the actual image so that it basically repeats. It looks like this:

The problem

So on the right edge you see a line of pixels that juts out. Same with the bottom of the model. Even at the top of the model you can see a small indent as the texture is tiled.

So my question is, what do i need to do to prevent this seemingly random defect that, despite my complete lack of understanding of 3D creation or programming, should logically not happen?

$\endgroup$
  • $\begingroup$ I followed the same steps: imported your image using image as plane, subdivided and added the displace modifier with the same settings and don't get the same error: i.stack.imgur.com/sgHgT.png check that you select the correct UV map in the modifier. Else, re unwrap the plane to make sure the edges of the image are used. $\endgroup$ – cegaton Nov 27 '15 at 21:30
2
$\begingroup$

It sounds like the "Import Image as plane" add-on did not UV map it correctly. If that is the case, then you can fix it by hand.

For fixing it, scale the UV map in the UV/image Editor while in Edit mode with the desired image in the editor. Or by going into top orthographic view and using the "Project From View (Bounds)" function by pressing "U".

$\endgroup$
1
$\begingroup$

For a quick and easy fix:

  1. Select the object.
  2. Select the "Texture" tab on the right menu panel.
  3. Ensure your height map texture is selected from the list of available textures.
  4. In the "Image Mapping" section of the texture tab, set "Extension" property to "Clip" (instead of "Repeat").

Extension:Clip

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.