0
$\begingroup$

I have a small scene with an imported CAD model in Blender 2.9. I have textured a vastly similar model before and imported the textures from the old project (Blender Version 2.82) into the new one.

The preview in the material tab displays the texture correctly (A). When I apply the material to any imported object in my scene, I only get a solid color material without texture. This applies to the viewport as well as a rendered image (1). When I copy the object the material was originally applied to from the old project file, it is displaying correctly in my current scene (2). When I create a new mesh and apply the texture on it, it is also displaying correctly (3). (A)

What could be the reason for the tiled texture is not displaying on the imported objects? You can download the full project file and take a look yourself. https://filebin.net/1jzdwh6t52jtfioi/Texture_issue_scene.blend?t=pm3p6t1q

$\endgroup$
3
  • $\begingroup$ I didn't check your file, but isn't that your CAD model is missing a UV map? $\endgroup$ – vklidu Feb 23 at 7:56
  • $\begingroup$ I tried to work with UVs and I unwrapped the object in question. It didn't solve the issue and the old object wasn't unwrapped either, yet it still seems to be working. $\endgroup$ – Croomar Feb 23 at 8:00
  • $\begingroup$ Please for a next time share just simplified blend file, like only object 123 seems to be enough to see issue. $\endgroup$ – vklidu Feb 23 at 8:13
0
$\begingroup$

Object 1 doesn't have an UV map, object 2 have.
When I Unwrap object one, like Cube projection or if you go to top view and Unwrap from View, it works for me.

enter image description here

$\endgroup$
2
  • $\begingroup$ Well, that makes me look like an idiot :) Apparently, when I tried unwrapping last time, I did something wrong. After reading your comment I tried it again with cube projection, now it works. Classic issue, classic solution. Thanks for your effort. $\endgroup$ – Croomar Feb 23 at 8:26
  • $\begingroup$ No problem. We all have those ... :) We use to say "The greatest darkness is under the candlestick". $\endgroup$ – vklidu Feb 23 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.