0
$\begingroup$

I want to set a texture on one side of a cube, but it shall only be very small. So I selected this one face in edit mode, “unwraped” it (i. e. created a UV map with just one face), and scaled it up in the UV/Image Editor.

When I now create a material and an associated texture, load my image, set Image Mapping → Extension to Clip and disable Mapping → From Dupli, there should only be one image, but it is always tiled over this face instead.

Tiled texture on one face of cube Data tab of texture

Of course, furthermore, the whole cube should be green, as there is only one material. However, it works in Viewport Shading “Rendered”:

Correctly cropped texture in viewport shading “Rendered”

But this is not good enough for me, I need it in Viewport Shading “Material”, too. Is there a trick that helps me? Or is this viewport shading not able to clip (so missing feature or bug)?

I use Blender 2.79, Blender Render and Windows 10 64 bit.

$\endgroup$
0
$\begingroup$

As far as I know OpenGL viewport preview doesn't support texture clipping options, so they will always display tiling infinitely.

Also viewport material preview is quite limited, it is meant as a reference only.

They should render properly when pressing the F12 key regardless of render engine, though, except of course OpenGL renders.

Also see How do I Make a Transparency to Decal my Object? (Blender Render Only)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.