2
$\begingroup$

Blender 2.93, so basically i made a simple table lamp and assigned the material translucency, but the problem is that inside of it is dark, outside is bright, but the light doesnt go through the object with translucensy and doesnt hit the wall, making this big shadow in the middle, and the shadows are weird too, they are all circles. How can i make the light go through the object and lighten those black parts?

enter image description here

$\endgroup$
5
  • $\begingroup$ did you try with cycles? $\endgroup$
    – Chris
    Dec 6 '21 at 7:01
  • 2
    $\begingroup$ For the round shadows - each round is one sample of your eevee render, if you want it to be smooth as it is supposed to be, you need to use more samples in viewport and render (try 300) and also give shadows more details 4096px... for the black inside, that is simply because combination of eevee and translucency will not give you exactly right result (if you need eevee you need to find a way around, if not, you should use Cycles $\endgroup$
    – MikoCG
    Dec 6 '21 at 7:08
  • $\begingroup$ The scene that has this lamp has many other objects that cause it too long to render, so eevee were faster than cycles that took too long to render. I pretend to use this scene to make like a comic so i will be rendering lots of ímages of it, and that's why cycles will slow dow everything... $\endgroup$
    – Silly3D
    Dec 6 '21 at 7:28
  • $\begingroup$ unfortunately, it is true Eevee has its limitations, it is render engine based on an approximation to make it fast and that actually makes it less realistic (less quality = more speed) that's why I said that if you need to do it, you need to find the way around that works specifically for Eevee $\endgroup$
    – MikoCG
    Dec 6 '21 at 7:33
  • $\begingroup$ @Silly3D Apart from my explanations in the answer why it looks wrong: If you have to use Eevee, I would suggest you put a second point light inside the lamp. While the original one has a Power of 1000 W and a Radius of 0.25, give the second light a larger radius like e.g. 1.00 and a lower power, maybe 100 W, to simulate the translucent indirect lighting. Maybe I'll add this as solution. $\endgroup$ Dec 6 '21 at 7:38
7
$\begingroup$

The light cannot hit the wall in the shadowed areas because you are using Eevee. Eevee is no raytracing engine like Cycles, for the same reason mesh objects with an Emission shader emit no light onto surfaces in Eevee. The light is visible in the Translucent BSDF material and will receive shadows if there is an object between the light and the material, but the material itself will not emit indirect lighting like in Cycles. I think there is a way to Bake Indirect Lighting in Eevee, but I'm no expert for this (maybe someone else can help). But it doesn't work by default.

So in your setup all light on the walls can only come through the open top and bottom of the lampshade. The edges of those openings create shadows, and because Eevee is set to Soft Shadows by default and the Viewport Sampling is set to a low resolution of 16 by default, these soft shadows look bad because Eevee just mixes many hard shadows to create the soft shadow. If you increase the sampling to e.g. 256, they will look better.

The dark inside of the lampshade is caused by the fact that you use only a Translucent BSDF in the material. This has no information about the surface other than it lets light shine through. No diffuse surface color, no roughness, no glossiness etc. so there is no surface information on how to reflect the point light. In Cycles it's different, since the translucency "captures" light (not physically correct explained, I guess), it emits a little bit indirect light to the inside as well, but not as much as to the outside. In both render engines it is recommendable to mix the Translucent BSDF with some other shader like Diffuse BSDF or Principled BSDF. Otherwise your lampshade will be very dark in Eevee when the lamp is turned off and the lampshade only gets light from the outside.

EDIT: These are the reasons for the way it looks in your original file. Now that I've learned that you have to or prefer to use Eevee, here is a small workaround to fake the indirect lighting:

Put a second point light inside the lamp. While the original one has a Power of 1000 W and a Radius of 0.25, give the second light a larger Radius like e.g. 1.00, large enough to extend the borders of the lamp shade. Then set it to lower Power, maybe 100 W, to simulate the less intense translucent indirect lighting. Together with a higher sampling rate this will look much better. If you can't afford the higher sampling rate you maybe have to switch off Soft Shadows and have to go with hard ones.

fake indirect light

$\endgroup$
6
  • $\begingroup$ I think thats is the only solution, but the dark inside of the light stills remains, that make it looks strange like a lamp inside something and is dark, but is the best i can get with eevee. $\endgroup$
    – Silly3D
    Dec 6 '21 at 16:48
  • $\begingroup$ Would baking the indirect lighting work here? $\endgroup$ Dec 6 '21 at 18:03
  • $\begingroup$ @Silly3D I explained in the answer that the dark inside is caused by using a Translucent BSDF only without mixing with a Diffuse BSDF or Principled BSDF, which I would recommend even when you're using Cycles. So it's all in the answer. 😉 $\endgroup$ Dec 6 '21 at 20:19
  • $\begingroup$ @MartyFouts As I said in the answer, baking indirect lighting might work here, but I'm not experienced in this and I guess it would make things more complicated whereas the second lanp is an easy workaround which is more flexible since no baking is involved. $\endgroup$ Dec 6 '21 at 20:22
  • 1
    $\begingroup$ Mixing diffuse with translucency fixed it. now i got a really good result. $\endgroup$
    – Silly3D
    Dec 6 '21 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.