2
$\begingroup$

I'm trying to animate a character that I have created with blender 2.71, but something doesn't work well. As you can see from the screenshot, I have created the bones, I pressed Ctrl + P and then I have chosen the option 'With Automatic Weights'.

enter image description here

However, when I right click on a bone and I try to move it, the meshes of the character don't move; Only the bones do it. What am I doing wrong?

$\endgroup$
  • 1
    $\begingroup$ You may have to manually weight paint. Without a .blend file, it is hard to tell. If you could upload it to Pasteall.org that would help us figure out what the issue is. $\endgroup$ – VRM Nov 22 '14 at 20:51
  • $\begingroup$ try to get the file here,because pasteall.org doesn't work for me : psychonews.it/pics/boy_moving2.blend $\endgroup$ – Marietto Nov 22 '14 at 21:32
2
$\begingroup$

In Object Mode select all objects but the armature. Press Ctrl-J (join) .

Parenting with Automatic weights fails due to duplicated vertices. With the mesh selected enter Edit Mode select all A then press the Remove Doubles button from the left panel this removes > 3700 vertices.

You probably need to manually edit the middle part of the body because it is not connected. Or try to increase the limit when removing the doubles.

Note that this could also be done with a Mirror Modifier set to clipping.

After parenting with automatic weights your model requires weight painting. In your case I wouldn't recommend to use automatic weights because it adds much weights you only need to remove. Better paint it all manually from scratch.

enter image description here

$\endgroup$
  • $\begingroup$ What worked for me was to first clear parents using alt-p, between Mesh and Armature, then do the parenting again, for some reason after uv-unwrapping the parenting was changed. $\endgroup$ – user1420482 Jul 29 '17 at 4:27
1
$\begingroup$

I had a similar problem to the above. I had a part of my mesh that was weighted to a particular bone, but when I moved the bone, the mesh didn't move. After trying many of the steps listed above to no avail, I finally thought to glance at the bone's properties.

enter image description here

As it turns out, the deform property for that bone was disabled somehow. Once it was re-enabled, it worked as expected.

$\endgroup$
0
$\begingroup$

I found the problem for me... I scaled, rotated and moved the mesh and the skeleton in object mode. Meaning the object center of both of them doesnt match. Set the position and rotation in object mode on all axis to 0 and set the scale to 1 (for both skeleton and mesh) Go to edit mode move your mesh and rig around and make everything fit. Now go back to object mode make sure position, rotaion and scale are still the same for mesh and skeleton... if so you should be able to parent your stuff properly.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.