1
$\begingroup$

So I'm new to blender and I've been playing around with bones and meshes. What I'm trying to do is creating a skeleton for my character, without using automatic weights. I don't want to use automatic weights for 2 reasons:

  1. I want to learn how it works
  2. The automatic weights add all vertex groups to the mesh, which I do not need since my characters is a voxel model so I don't need stretching (one bone mostly moves one mesh)

I have done the following, but I am missing something, the bone moves, but the mesh does not move with it.

  1. Created a bone as a child of another bone
  2. Added a vertex group to the mesh, with the same name as the bone
  3. Set the weight of that vertex group to '1', using the slider in edit mode, and clicked 'apply'
  4. Added a armature modifier to the mesh, with the correct armature set (only have one so it's hard to miss)
  5. Made the bone a parent of the mesh, or the other way around (I'm not sure, clicked the mesh, then the bone, then added as parent using ctrl-p).

However, when the bone moves, the mesh does not move with it. When I use automatic weights, it does work. Which leaves me to conclude I'm missing a step, but I cannot figure out which one.

Thanks for reading, appreciate it!

$\endgroup$
9
  • $\begingroup$ You should have parented With Empty Groups, which would have created all the group but would not have assigned any vertex, you would have done it with the vertex groups Assign button. But the way you did should work as well, you need to parent the object to the armature though, not the opposite. If it still doesn't work, please share your file: pasteall.org/blend $\endgroup$
    – moonboots
    Nov 18 '21 at 12:17
  • $\begingroup$ @moonboots Thanks for your response. I will try the empty groups tonight, and will share the results or file. $\endgroup$ Nov 18 '21 at 12:51
  • $\begingroup$ @moonboots Hi, I have tried with empty groups, however, that results in the same thing as with automatic weights. It creates a lot of vortex groups on the mesh. Is this how Blender was intended? Because it seems odd to me. Btw, I have uploaded the blend file, see: pasteall.org/blend/fa8deb0b42b54b43bdf04b3184bdc2f8 - take for example the right upper leg, which i have named right upper leg due to a mistake $\endgroup$ Nov 18 '21 at 15:57
  • $\begingroup$ oh ok because you've kept all the objects separated. There are 2 ways of doing it, either you keep them separate and you select one object, shift select the armature, switch to Pose mode, select a bone and Ctrl P > Bone. Or you join all the objects into one (Ctrl J), select the body, shift select the armature, Ctrl P > With Empty Groups, then select the body only, switch to Edit mode, select a piece (a mesh), go into Object Data > Vertex Groups, select the group this vertices should be part of and press Assign. $\endgroup$
    – moonboots
    Nov 18 '21 at 16:04
  • $\begingroup$ I recommend the second solution but you may prefer to keep separate objects for some reason? $\endgroup$
    – moonboots
    Nov 18 '21 at 16:04
0
$\begingroup$

If you keep the pieces separate as separate objects, select one object, shift select the armature, switch to Pose mode, select a bone and CtrlP > Bone.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.