0
$\begingroup$

I modified a character model which I downloaded from somewhere, then added an armature so that I can animate. I started in the lower right area (the foot) , the extruded each bone from there.

When parenting the armature with the character, I did ctrl+p-->deform armature-->automatic weights.

When I go into pose-mode to rotate and move the bone, hoping that it would move my characters boot, it doesn't. I learned that I might have to manually paint weights, so I did that with the left foot. I then tried moving the bone again (pose mode), still, the boot doesnt move at all.

My character is a "santa", which has many different objects like boots, right leg, left leg, hat...

(OLD)

NEW EDIT:

Alright I solved the bones not working. I think it was I started it in the foot and not the pelvis. I might not have selected the objects entirely that were to be children to the armature. Now, I have this: blend_new_issue

(https://imgur.com/a/GOtdpmy)

It seems that the transform of every object has reset. You can see the tiny armature in the center (not actually the armature, but a bone which is selected in blue).

What I did this time was make a new file, import my character, add armature in pelvis area, then extruded to each area. I selected all objects in Object Mode with 'a', then deselected and reselected the armature in order to make sure that it's the last selected for parenting. I did Ctrl + P --> armature deform --> with automatic weights. When doing this the last time, my computer didnt go under a load. This time it did. My cpu went up to 95% usage and blender stopped responding. After 2 or so minutes, blender was responsive, then my scene/mesh looked like the above.

$\endgroup$
0
$\begingroup$

First of all, you need to join all this character's meshes into one object by selecting them all then pressing ctrl+J. This will confuse the normals, so in edit mode select all then press ctrl+N. The armature and mesh need to share the same origin point. Press ctrl+S to snap the cursor to the center. Select the mesh and press ctrl+alt+shift+C. Do the same with the armature. Meshes downloaded from the Internet or generated from a different program can have some funky reactions when they're parented to a rig. I'm not sure why that is, but to fix it, you can scale down the mesh in object mode then apply the transformation by pressing Ctrl+A. Automatic weights aren't always guaranteed to work properly, especially if it has to deform an object made of separate meshes. You'll have to manually weight it. Be sure to convert those tris to quads (ctrl+F) to make that process easier. Cut down on those vertebrae too- only two to four are really necessary. Hope this helped.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.