2
$\begingroup$

I'm working with UV Project modifier in Blender 2.81a but can't achieve the exepected result as shown on the documentation page. I've seen other questions regarding the Project modifier but all seems to have it work out of the box.

Taking the example project I don't see the texture applied to Suzanne. I've tried to change the viewport shading to no avail. I tried both with and without applying the modifier on Suzanne first.

Which settings should I use in my view port to see the projected image on my mesh object?

Additionaly, I tried to visualize the projected UV map but the UV Editing workspace does not display any UV map. I tried to unwrap different objects (which work in a virgin project) but I didn't manage to see or play with any UV map.

Any help would be appreciated!

$\endgroup$
2
$\begingroup$

The example project seems to be a bit outdated, I took it and added a shader with a checkerboard texture, that works fine - all other settings do indeed work in that file. Just add this shader network to the monkey:

enter image description here

Then you can change the mapping by moving the projector, which in this project is the lamp.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Not sur to get what you mean by "changing the mapping". I only get the checker texture applied to Suzanne and not from the Lamp perspective. Shouldn't I be using the UV Map input node? $\endgroup$ – vwvw Jan 7 at 11:14
  • $\begingroup$ See in the picture above, it is using UV coordinates indeed. You can also use the UV Map input node, that gives the same result in this case. What happens to the texture on Suzanne when you move the lamp? $\endgroup$ – tobkum Jan 7 at 11:27
  • $\begingroup$ Oh, you are correct! Didn't try it this way! But why is the back of Suzanne also textured? I would have expected it to be black as the projection can't reach it. $\endgroup$ – vwvw Jan 7 at 11:30
  • $\begingroup$ Ah, nice! The projection "goes through" the whole object, so all backsides and obstructed parts get textured as well. $\endgroup$ – tobkum Jan 7 at 11:31
  • $\begingroup$ Ok! Is there any way to disable the "goes through" property? It seems at least in the example some parts of Suzanne are black. $\endgroup$ – vwvw Jan 7 at 11:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.