29
$\begingroup$

What's happening is that I have tried to flip the normals, inside and out, but there are always faces which have to be flipped!

Normals recalculated Normals re calculated

Inside View

Inside view

If I flip them again, all faces get flipped and end up horrible and, not working at all. So how can I make all of the faces flip to the right direction?

$\endgroup$
  • 1
    $\begingroup$ try creating a series of models that are saved as you progress in them/get them ready for other programs. for example, whenever you get to a certain point, such as manually correcting the normals. this way, if your normals mess up for whatever reason during a session, and it is only part of the model, you can find again that part of the model as correctly from a previous version/file. i wouldn't be afraid to be too generous in saving the files (sometimes i so something like example.1.2.5.2.blend at times if i am unsure as to the changes i am making but want to progress anyways). hope it helps. $\endgroup$ – pink flamingo Oct 29 '19 at 17:15
26
$\begingroup$

TL;DR: Select all and press ShiftN to Recalculate Normals (CtrlN in 2.7x and earlier).


I think this is problem you are having: some of the normals are always facing the wrong direction.

If you have the whole mesh selected when you flip normals then you are just toggling between the backwards faces and the correct faces, what faces are backwards. You are flipping the whole mesh, the correct parts will become backwards.

Whilst in Edit Mode, with the whole mesh selected, Recalculate the normals. That should fix the problem.
If recalculating the normals does not fix it, then you will have to go through your mesh and select only the faces that are backwards then flip normals.

I think you want the inside of the scope to point towards the inside. That is a case where Recalculate will probably not work. If the inside cylinder is unconnected from the rest of the mesh, then just hover the mouse over the inner cilinder and press L.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Yes , I had to flip the normals which werent flipped correctly because no other solution wasnt working! , It was quick though ( i used ALT P to select the circle of faces ) $\endgroup$ – Knuckles209cp Jun 13 '14 at 8:58
  • $\begingroup$ ctrl N for me seems to want to make a new document. $\endgroup$ – Trejkaz Dec 28 '17 at 8:16
  • 3
    $\begingroup$ @Trejkaz you have to be in edit mode. $\endgroup$ – David Dec 28 '17 at 13:56
  • 1
    $\begingroup$ In case anyone is having an especially coffee deprived day, ctrl N is ctrl + shift + n. $\endgroup$ – Shane May 31 '19 at 8:04
  • 2
    $\begingroup$ @Shane I think you are mistaken. In 2.79, it is Ctrl N and in 2.8 it is Shift N. $\endgroup$ – Leander Oct 29 '19 at 19:29
18
$\begingroup$

You can use "make normals consistent" enter image description here enter image description here

To find out which direction ther normals are pointing at you can enable "normal" in the mesh display tab.

enter image description here enter image description here

| improve this answer | |
$\endgroup$
5
$\begingroup$

I guess you ticked backface culling in the Options Panel N in section Shading.

enter image description here

Check your normals again with the Normals display option ticked.

This image shows a cube with a single face removed, the normals should all point outwards. due to the deleted face all the faces with normals pointing backward are hidden. The faces with normal pointing in to the viewers direction are displayed.

The materials also have a backface culling option (in game mode).

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Nope , that doesnt fix it :l $\endgroup$ – Knuckles209cp Jun 12 '14 at 9:12
  • $\begingroup$ @Knuckles209cp add more details if this doesn't help consider to upload the file. $\endgroup$ – stacker Jun 12 '14 at 9:19
5
$\begingroup$

Go to Edit Mode > Face Select then press A Select all > Recalculate Normals Shift + N

| improve this answer | |
$\endgroup$
2
$\begingroup$

To recalculate normals and change face orientation

  • Go to edit mode
  • select the faces,
  • Shift + N (in blender 2.8 and above)
  • Ctrl + N (in blender 2.79 and below)
| improve this answer | |
$\endgroup$
0
$\begingroup$

While the question is rather old and solved, it's still an important and underestimated topic leading to other questions coming up, so i would like to add one approach i did not see in the available answers here, for completeness sake.

Normals (or the orientation of the faces) in Blender can be made visible in 2 ways, one way would be with little lines pointing outward from the middle of a face, specifically the face-normals, while it gives us the information we may need, it can be hard to see wrong directed normals on complex geometry and long stretched faces, if you are a bit zoomed out.

enter image description here

Here i would suggest the Face Orientation to help get an easier overview on where there are faces in the wrong direction. Front and back of the face become blue and red respectively to have a strong contrast and allow better visual identification.

enter image description here

While it is easier to spot with the Face Orientation it does not replace the Normals as those i compared were only the Face-Normals. But something that happens often is that we work on geometry and apply subdivision surface modifiers to name one that makes most obvious problems with wrong Normals, just to then have to find out that a face got turned for whatever reason.

So i would like to suggest to switch on Face Orientation at least once before giving up on surface problems, most likely if it turns out to be the Normals, the solution is underestimated easy.

Be it with recalculating Shift+N to let Blender figure out what's in- and outside, or by selecting the wrong ones manually and flipping them with Alt+N selecting "Flip". One thing to keep in mind though, both functions need you to select the faces you want to affect!

| improve this answer | |
$\endgroup$
-3
$\begingroup$

Select the entire model by pressing, A then Ctrl+N to change the normals to face out.

| improve this answer | |
$\endgroup$
  • 3
    $\begingroup$ Essentially the same answers as before but 0 explanation. $\endgroup$ – stephanmg Mar 27 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.