4
$\begingroup$

This question already has an answer here:

Thanks for any assistance you can provide on this. I've been iterating on this for a while now and am somewhat flummoxed by the problem.

I have a small .blend file here which illustrates the problem:

https://dl.dropboxusercontent.com/u/21819517/example3.blend

This object (a scroll and pegbox for a violin model) is enclosed and has no non-manifold geometry or duplicate vertices.

On the bottom front right of the mesh, you see that the mesh tapers down. On the bottom left, I've moved two vertices out slightly to demonstrate the problem.

When the bottom part of the model is shaped like this on both sides (as it is on the right side of the mesh in the .blend file):

Model without normals problem

Everything works fine.

If, on the other hand, the model is modified like so:

Model with normals problem

Then recalculating normals does not work properly. Blender flips normals improperly.

You can see this for yourself by opening the .blend file I posted above, pressing A and CTRL-N. If you move the edges back so they are not in front of the rest of the model, it works correctly.

My question is: Is there something wrong with this mesh to make it do this? Or is there a bug in Blender? I'm concerned that there's a problem in my mesh that makes it hard to determine the inside and outside, so I'd like to resolve it if there is.

I'm using Blender 2.73 on Windows 8.

Thank you for any assistance you can provide!

Edit: I don't feel this is a duplicate, based on the question linked. I've provided a specific example that demonstrates a reproducible scenario of incorrectly calculated norrmals.

$\endgroup$

marked as duplicate by Ray Mairlot, someonewithpc, iKlsR Feb 25 '15 at 4:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ seems to me they are all already pointing in the right direction, or at least uniformly as a continuous mesh. If you recalc it appears to flip normals, maybe because they are uniform. Flipping again seems to result in good geometry here. $\endgroup$ – zeffii Feb 23 '15 at 15:20
  • $\begingroup$ It looks like something about the algorithm, which causes all normals pointing inward in that case. The reason why it looks strange is the "Backface Culling" is enabled. Solution: If Ctrl N isn't what you want, just Ctrl Shift N to flip them to the opposite direction. $\endgroup$ – Leon Cheung Feb 23 '15 at 15:23
  • $\begingroup$ I enabled Backface culling to see where the normals were incorrect. I can certainly just invert them, and getting the normals to be correctly oriented isn't a problem- my question is more about why Blender can't seem to detect the outside of the mesh correctly in this specific case. If it's just a simple "eh, that happens sometimes", that's OK- I'm concerned that there's something either wrong with my mesh or I did something improperly, as I'm still fairly new to Blender. $\endgroup$ – Corey Snow Feb 23 '15 at 15:25
  • $\begingroup$ I just fiddled a little with it, by gradually pulling the "foot" further out, and my only conclusion is that the sharpness of the angle causes the algorithm to fail. I certainly agree that this isn't a duplicate, but I think it qualifies as a bug report, and should be closed anyway. $\endgroup$ – user7952 Feb 23 '15 at 15:57
  • $\begingroup$ If it's a bug, I'll look into how to file it with the Blender project. I gather they like to find these and squash them. Thank you! (I need to learn not to hit enter in this field, heh). $\endgroup$ – Corey Snow Feb 23 '15 at 16:26

Browse other questions tagged or ask your own question.