0
$\begingroup$

Before I continue, I probably should mention that I already have tried copying vertex groups and mirroring there and also mirroring through the weight tools (I believe it's the same thing, but still), have X Mirror option enabled as well (yet it looks like it ignores it for some reason). The model is centered in the scene, everything looks fine, vertex groups names should be fine as well. No idea what's going on there, but whenever I try to copy one vertex group to another Blender hiccups and shows a error, that says: 0 vertices mirrored, 228354 failed.

Here's the file with the problematic mesh: https://drive.google.com/open?id=0B73O5HTSV-kHZ0hldVJ6RDdYMGM

So, as you can tell that last rigging part basically now has killed the whole work I did there. Thanks in advance, kind people, I really hope that some Blender veteran knows what's going on.

$\endgroup$
1
$\begingroup$

Turns out the mesh itself was unsymmetrical and that caused all problems in the end. The solution was to select all vertices of the mesh in Edit Mode and apply Symmetrize function.

$\endgroup$
0
$\begingroup$

welcome to Blender SE.

I got a small portion of the mesh mirrored (4723 out of 218908) by checking off All Groups and Topology Weights in the mirror tool options in weight paint mode.

enter image description here

By the way, while the armature object is centred on the x-axis, it isn't fully zeroed out on y and z. That may not matter for mirroring weights, but that could pose problems (no pun intended) if you proxy your rig into another scene file. Also, you might be able to throw a decimate modifier on your mesh and lower the poly count. I tested it on 3 iterations and it looked pretty good still.

$\endgroup$
  • $\begingroup$ First of all, thank you for the answer (wow, that was fast). Sadly, it didn't help. Fixed Y and Z too. Already had what you've mentioned unchecked, tried to play with those settings and the only thing I got was 44 vertices out of 29289. Spent so many hours on that thing, there should be a solution or this mesh will have poor weights forever. By the way, thanks a lot for mentioning Decimate modifier, I was looking for that today. $\endgroup$ – Art Jan 14 '17 at 1:21
  • $\begingroup$ Hmm weird, not sure why your having no luck on the mirror. I would retry the mirror tool after taking the poly count down. The mirror tool doesn't handle a high polys well. Also, did you have those mirror options unchecked? I mean try checking them. $\endgroup$ – Mike Belanger Jan 14 '17 at 1:26
  • $\begingroup$ I finally figured it out. Turns out the mesh itself was unsymmetrical. I was sculpting for the very first time and I didn't turn on the mirror function right away as I remember now. That caused the mesh having different vertices for one side. Silly me. Just used the Symmetrize of Edit Mode in the end. Thanks for the help once again, Mike. $\endgroup$ – Art Jan 14 '17 at 2:14
  • $\begingroup$ Glad you figured it out. I was about to suggest doing a fresh mirror modifier, you beat me to it. $\endgroup$ – Mike Belanger Jan 14 '17 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.