0
$\begingroup$

Update:

Any mesh with mirror modifier in the new blender version seems to cause the side that is not mirrored to take over the complete control of the vertexes in the mirror plane.

Not sure if it's a bug, but a workaround is to apply the mirror modifier, as I said in the original question. I have reported this, as I didn't see anyone experienced the same thing.


Original question:

I have been a whole day looking what's wrong, but I wasn't able to find anything useful.

I have a symmetrical armature (generated by rigify and symmetrized before and after the generation), with a symmetrical mesh (with mirror modifier).

Applying automatic weight results in the following weight paints:

non-symmetrical weight paint

Which is not symmetrical. Only shoulder and upper_arm vertex groups are affected (i.e., not symmetrical, the rest are symmetrical).

Well, then I tried to find the problem:

  1. Other meshes are not influenced. Thus, I think it's not due to the armature
    • I did symmetrize the armature many times, with no luck
  2. If I apply mirror modifier and set the automatic weight, this problem goes away and everything works as expected
    • However, other meshes also have mirror modifier but do not suffer this
  3. All meshes come from my old project, which also used rigify, but do not have this issue. Therefore, the statement in 1 might be wrong
    • I append the meshes, and added the same modifier (mirror, solidify, etc.)

There are some posts indicate that first apply the automatic weight and then mirror might solve the problem, but it still leads me to the same result above (I have deleted all vertex group before the automatic weight).

In fact, the Mirror Vertex Group option has no effect at all, and I suspect there's some problem there.

  • If I paint the something, it does "mirror" the weight paint, but the left side has always bigger weight paint than its counterpart.
  • The side with more weight paint is the mesh I created, being the other side created by the mirror modifier, if that matters.

painted weight

Any suggestion would be appreciated, thanks.

$\endgroup$

1 Answer 1

0
$\begingroup$

To solve this issue in 3.1.2 at least you need to expand the Make Parent modal at the bottom left of the viewport which becomes available after you Set Parent To, and then tick the X Mirror checkbox.

I never had this issue with previous versions of Blender, so this must be some new change that defaults to a disabled X Mirror.

Older rigged files appear to work normally when you re-parent the object to the armature because the X Mirror option is already checked on for it in the Make Parent model.

It all looks like a bug, but in reality it was a bad design choice.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy