4
$\begingroup$

I've been studying more and more about creating normal maps and texturing the mesh. However, I can' t really find a solution for my question in the Internet and I was wondering maybe you could help.

Here's the problem. I baked the normal map for the mesh by creating a duplicate of the mesh and making some details on the duplicated mesh with multires modifier. However, the normal map creates really weird shapes on my mesh. I was wondering and read that the problem can be caused when I have small amount of seams when creating UV map.

Also, there are some really weird holes in my UV map, might it be caused due to fact that the meshes aren' t at the same exact place?

Here' s a pic for illustrating my problem: enter image description here

Here's a little bit better picture of the problematic place of my mesh + additional view of my material nodes. enter image description here

The problem is somehow associated with the neck of this humanoid. I made a duplicate of the face and just raised the level of the multires modifier. Whenever I raise the level of multires subdivisions, it will look like this. When I remove the modifier, it won' t affect the mesh.

enter image description here

$\endgroup$
  • $\begingroup$ Could you post a zoomed version of the normal map showing the interested area? And your material's node setup too? $\endgroup$ – Carlo Sep 14 '15 at 21:49
  • $\begingroup$ Ye sure. In addition, I have some more questions about the smooth vs flat shading when baking normal maps. Is it really so, when you bake normal map with flat shading, you need have higher polycount so it wouldn' t look ugly? With smooth shading however, it just looks a bit ugly, I want my mesh to have sharp wrinkles for example. $\endgroup$ – TheLast_BlenderBender Sep 15 '15 at 8:21
  • $\begingroup$ I think that it's very strong, so try to decrease the value in the node "Normal Map", try to reverse it, too. $\endgroup$ – YasirAnqa Sep 15 '15 at 8:41
  • $\begingroup$ The normals are not correctly projected from high to low. Probably the cage you are using is not good enough, but without seeing it I cannot say more. Consider to upload your blendfile on blend-exchange.giantcowfilms.com. (Bounus advice: plug the normal map output in the shader's normal imput. It's not related with the normal baking proces but it will give better shading results when you'll fix the normal map.) $\endgroup$ – Carlo Sep 15 '15 at 10:55
  • $\begingroup$ The problem with adding it to blend-exchange is that the file itself is too damn large. it's approximaely 70 MB's... How do I adjust my file size (I have the whole body with modifiers applied - there are clothes, boots, leggings, hands, head, headwear). You are allowed to facepalm on my situation :D $\endgroup$ – TheLast_BlenderBender Sep 15 '15 at 14:06
1
$\begingroup$

I was struggling days to find out what caused the problem with baking normal maps and think I found a nice solution. I could have used much easier way to bake normal maps for my mesh. To bake normal map for my mesh, I needed to do the following:

  1. Have only one mesh for baking normal map

  2. Use multires modifier on that object

  3. Raise the levels of subdivisions as high as I need to have nice details

  4. Once I've created details in sculpt mode, go to Cycles Render Engine

  5. Go to "Render" tab and open "Bake" option

  6. Make sure that "Selected to Active" is disabled (becaused baking normal maps with this option is based on other method)

  7. Change "Bake Type" to "Normal"

  8. Hit the "Bake" button and be happy to have good normal map.

This way of baking normal maps for mesh is usually used when your mesh has fine topology (the mesh consists of square-shaped faces and not triangles), because multires modifier will subdivide all faces and mesh that consists of triangles, will deform the mesh alot. However, it's easier to subdivide squares and it doesn't cause any problems this way.

$\endgroup$
  • $\begingroup$ I'd say you should have added for clarity that if baking normal maps from Multiresolution modifier then: 1) you set its Preview option to something lower 2) work with only one mesh (as opposed to baking from high poly to low poly method). $\endgroup$ – Mr Zak Sep 17 '15 at 22:11
  • $\begingroup$ Yes. I feel I should have done that. Next time I am smarter then :) Thanks. $\endgroup$ – TheLast_BlenderBender Sep 19 '15 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.