0
$\begingroup$

Don't know if it's just because 2.8 is still in the process of making, but here's my problem. I have this man mesh (from cgtrader) that came with a normal map and this texture that matches it to put color in the right place. The problem: It comes out black. I've looked everywhere and this seems to be the right node setup, but help is appreciated. Thanks!

The Nodes:

BTW here's the link to the mesh I downloaded if you wanna try: https://www.cgtrader.com/free-3d-models/character/man/3d-character-96a5df4b-49ab-411b-9e1d-fd6e47537e41

$\endgroup$
  • $\begingroup$ If it is a real normal map you don't need the normal map node. $\endgroup$ – cegaton May 23 at 0:53
  • $\begingroup$ okay. lemme try $\endgroup$ – Corbomite May 23 at 0:54
  • $\begingroup$ Nope still black $\endgroup$ – Corbomite May 23 at 0:54
  • $\begingroup$ Your normal map node is currently set to "blender object space". Are you sure that is the correct space? "Tangent" is much more common, especially for a character model that may be rigged. $\endgroup$ – JtheNinja May 23 at 1:35
  • $\begingroup$ @JtheNinja switched back to tangent. still black. Not rigged btw $\endgroup$ – Corbomite May 23 at 1:41
1
$\begingroup$

If you change the normal map node from 'Blender Object Space' to 'Tangent Space' and select the 'UV map'in the dropdown that appears, that should work.

enter image description here

If it still appears black, then something else must be wrong. No lights, that sort of thing. I've uploaded my file (which is working for me), so you can compare: character.blend

$\endgroup$
  • $\begingroup$ Thanks. I have that box, but when I click on it, there's no map selection...How'd you do that part? $\endgroup$ – Corbomite May 23 at 2:37
  • $\begingroup$ In other words, which uv map option did you use? $\endgroup$ – Corbomite May 23 at 2:54
  • $\begingroup$ That map was already there for me, i.e. the model is already unwrapped. Did you import the OBJ file? That's the one I used. $\endgroup$ – edna May 23 at 3:34
  • $\begingroup$ Huh. I definitely will check that out and see if it’s works. Thank you! $\endgroup$ – Corbomite May 23 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.