1
$\begingroup$

enter image description here

Hi! So today I've been working on a hair mesh that is part of my personal project to my character that I've made. When I was checking on it's normal maps, I've noticed that some part of the NM have been darkened or even flipped and it all had to do with the normal maps I've created in Zbrush. For when I've looked into the hair with the highest subdivion and some points/vertices of it were raised on the other side, thus causing an unsymmetrical mesh. So what I've attemted to do was to smooth out those wrong incorporated vertices and tried to symmetrize them by using "Smart Resymmetrize" button. The Hair was perfectly symmetrized, I've created new normal maps with perfect symmetry and imported them to Blender. And here's where the problems kicks in:

enter image description here

When I've inserted the new normal maps for the hair, It gives of this weird and unbalanced shadow on one side, while the other was brighter. And I've mure that the point light was facing towards the frontal part of the hair (which is where the human face is located). I couldn't for the life of me figure out what's causing this problem. So If there's anyone who knows this, let me know. And here's the fixed normal maps: enter image description here

I know some of you will be confused by this of what I'm talking about, because I've been working on the mesh and writing this post almost at 12 pm. So i was kinda tired. But hopefully some of you will understand this to what I'm saying.

$\endgroup$
2
$\begingroup$

I recently experienced a similar issue. I found that, by default, images textures are set to sRGB;

enter image description here

Setting the normal map's image texture's color space to "Non-Color" should correct the issue;

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Oh, thank you so much! I really needed that information so badly. Really appreciating. To think iv'e forgotten one simple thing. Oh, silly me. $\endgroup$ – N Machado Apr 3 at 22:18
  • $\begingroup$ Don't feel bad, I've been using blender for decades and A: didn't know that until last week, and B: took me forever to figure out. Please mark this as the accepted answer for future users :) $\endgroup$ – AlexanderESmith Apr 3 at 22:22
  • $\begingroup$ @NMachado Please don't add thank you as a comment, upvote the answer instead. If you feel it completely solved your problem consider marking it accepted $\endgroup$ – Duarte Farrajota Ramos Apr 3 at 23:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.