4
$\begingroup$

I have added a plane in top view. I have then extruded the plane according to a floorplan in topview.

I don't know what happened, but when I switched my view, I could see that some parts of it are for some reason high up in the air.

I would like to ask how I can bring everything back down onto the grid / floor.

And if somebody could tell me how this might have happened, I would also be glad. mesh at different heights

$\endgroup$
5
$\begingroup$

Switch to object mode using the tab key, then press SZ 0 to scale the model to a uniform value on the z axis.

The result is that the selected region will be scaled to the median of all the selected vertices, effectively flattening the selection.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you very much! And do you have any idea how this might have happened? $\endgroup$ – tmighty Jun 27 '15 at 19:08
  • $\begingroup$ @tmighty: I'm actually not sure... probably you moved the 3D-Cursor accidentely. $\endgroup$ – PEAR Jun 27 '15 at 19:47
  • $\begingroup$ It may be good to mention that the transform pivot should be changed to the 3d cursor (which you should snap to one of the lower elements) if you want it at the same z level as the stuff below, before you do the steps here. $\endgroup$ – Qutorial Jun 27 '15 at 20:47
3
$\begingroup$

In side view and wireframe shading, border select B all the vertices that are too high.

From the 3D view header turn on snapping and change the "Snap Element" to Edges.

Now press GZ, and hover over one of the edges at the correct location, LMB LMB or Enter to confirm the transformation.
animated gif


That is using snapping, but you can also just scale the faces.

Keeping just the too high faces selected, select one of the correct height, and make it the active face.
Change the "Pivot point" to "Active Element", then scale to zero along the Z axis.
animated gif

| improve this answer | |
$\endgroup$
  • $\begingroup$ I have selected the "S, Z" reply because that was the most convient for me because I did not have to select individual parts of the mesh. $\endgroup$ – tmighty Jun 27 '15 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.