viewport:enter image description here

Render:enter image description here

Why do the edges become glossy when i hit render, but looks fine in viewport shading?

  • $\begingroup$ Do you have a hidden object in your scene that is still rendering? $\endgroup$ Commented Mar 25 at 17:03
  • $\begingroup$ nope, what is hidden in the viewport is also hidden in the render $\endgroup$
    – arafium
    Commented Mar 25 at 19:46
  • $\begingroup$ @arafium That might be true for objects (apart from "CameraTray_BodyTexture_0" and "Lenses_Lens_0" which are hidden in viewport but not hidden in render), but you have also different settings on modifiers. $\endgroup$ Commented Mar 25 at 23:05

1 Answer 1


The object "Body_BodyTexture_0" has a Solidify modifier which is disabled in the viewport, but enabled for rendering. When you enable it in the viewport, the shiny part becomes visible in the viewport as well. That is the first thing I found where you have things set up differently for viewport and render, probably there are more but this is at least responsible for the shiny part in your question.

enter image description here

  • $\begingroup$ thank you! you saved my life $\endgroup$
    – arafium
    Commented Mar 26 at 9:35
  • $\begingroup$ @arafium You're welcome. But it was already suggested by the first comment under your question, I would not reject something categorically without really checking it... some rendered objects were obviously hidden in viewport and though they were not the problem, as this solution shows you have to look for all differences between viewport and render. $\endgroup$ Commented Mar 26 at 9:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .