2
$\begingroup$

enter image description hereenter image description here

Why my "Render" viewport shading just looks like Material preview??? even I add the Light point? everything don't like render preview?

I have made sure that Scene Lights and Scene World are checked, so that isn't the problem:

Scene

$\endgroup$
2
  • $\begingroup$ Hi. I moved your image into your original question because it's a more fitting place. I also edited my answer to show another example. Maybe you'll find it helpful? $\endgroup$ Feb 1 '21 at 7:11
  • $\begingroup$ Not sure which step making wrong??? $\endgroup$
    – Chen Van
    Feb 1 '21 at 7:11
5
$\begingroup$

You may have "Scene Lights" and "Scene World" unchecked. If unchecked, the Material Preview lighting and reflections appear in your Render Preview:

Scene

This can also happen if you connect your materials directly to the material output without a shader, as seen below. If done this way, the material is considered "unshaded" and is thus unaffected by scene lights.

Shaderless

$\endgroup$
2
  • $\begingroup$ Thanks, I will go back to fix my notes, maybe I install the "Poliigon-material-converter" to messed up my notes. $\endgroup$
    – Chen Van
    Feb 1 '21 at 7:14
  • $\begingroup$ Thanks Christopher! $\endgroup$
    – Chen Van
    Feb 1 '21 at 7:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.