2
$\begingroup$

I've tracked a scene in Blender so that I could animate and adjust material lighting to an object placed in the scene. Once the footage was tracked, I set up a tracking scene and set the background.

Once I was happy with my animation I wanted to render with Cycles just the object animated without the footage in the background. Where can I disable the rendering of the footage?

$\endgroup$
  • $\begingroup$ This depends on how you got the footage to get rendered in the background in the first place - but try enabling Transparent in the Film panel of the render settings: i.imgur.com/qKIhnf6.png - otherwise check your compositing nodes. $\endgroup$ – Greg Zaal May 13 '15 at 13:42
  • $\begingroup$ once I was in the Edit Clip Editor, where the footage is tracked and the camera is solved, there are 2 buttons in the 'Solve' tab, under Scene Setup: Saet as Background and Setup Tracking Scene. These buttons set the clip as a camera projected background. $\endgroup$ – Novak Miler May 13 '15 at 13:59
  • $\begingroup$ The 'transparency' box is checked. Navigating around the scene in rendered view displays no background clip. It only apears throught the active camera since the camera is constrained to the solver. But I dont want the camera to include the projected footage in the final rendering. $\endgroup$ – Novak Miler May 13 '15 at 14:02
  • 1
    $\begingroup$ ok, I had to go into render menu, and under 'Post processing' I had to uncheck 'Compositing'. $\endgroup$ – Novak Miler May 13 '15 at 14:49
1
$\begingroup$

Unchecking Compositing in the Properties editor > Render tab > Post Processing rollout did solve the problem.
Side note: you can go to the compositing nodes in the Node editor (or choose "Compositing" screen layout) and change/remove the Source Movie to remove video from render.

$\endgroup$
  • $\begingroup$ I flagged this so a moderator can turn it into a comment hopefully $\endgroup$ – 10 Replies May 7 '18 at 22:12
-1
$\begingroup$

pre-compose the layer with the 3d track without the background. open pre-composed layer. export

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.