1
$\begingroup$

I asked a question before but I think the problem has changed enough to ask it in a new way.

I tracked some footage using the setup tracking scene button, and had issues with the rendering. I switched over to Cycles from Blender Render , and used Shadow Catcher. This seemed to work until I exported the render, which I think is placing the shadow below the tracked camera scene. When rendering, the image viewer shows the shadow background layer being rendered, but the final image doesn't have it.

Is there a way to bring it forward above the camera scene and below the object casting the shadow? This is a screenshot of my workspace. enter image description here

OKAY! I've done some work and gotten pretty good results. I believe my issue before was that I had objects on the wrong layers.

$\endgroup$
  • $\begingroup$ if you resolved your issue please write an answer to your own question. Other users that run into a similar situation might also learn from your exoperience. $\endgroup$ – cegaton Jul 6 '18 at 21:30
0
$\begingroup$

Well, I'd like to be more explicit in how I fixed it but basically, I went around and figured out that I had objects on the wrong layers. After I switched from Blender Render to Cycles I was still having issues, even though Shadow Catcher was a much simpler option. Even though the composite was working in Blender, it wasn't until I moved things to the proper layers that the shadow would show up. Now everything looks right and I'm on to my next challenge!

$\endgroup$
  • $\begingroup$ I don't understand what you do with your forground layer, inverting alpha and adding shadows. I would use it with an alpha over, or the shadows/AO passes with a multiply. what is the use of the invert and the 2 add nodes? $\endgroup$ – Bithur Apr 11 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.